Bug 1075384 - Flatpak prompts for root password at random times to update repos
Flatpak prompts for root password at random times to update repos
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
x86-64 Other
: P5 - None : Normal with 5 votes (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-10 14:02 UTC by Federico Mena Quintero
Modified: 2018-10-23 17:09 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Mena Quintero 2018-01-10 14:02:00 UTC
Flatpak and/or gnome-software prompt the user for the root password periodically, with a modal dialog; it seems that they want to update the repositories.  This dialog even appears over the lock screen when the machine is idle for some time.

I'm getting these messages after hitting Cancel in the root password prompt:

Jan 10 07:10:12 pambazo gnome-shell[2850]: JS WARNING: [resource:///org/gnome/shell/ui/modalDialog.js 218]: reference to undefined property "GdkX11Screen"
Jan 10 07:10:12 pambazo polkitd[1120]: Operator of unix-session:2 FAILED to authenticate to gain authorization for action org.freedesktop.Flatpak.appstream-update for system-bus-name::1.94 [/usr/bin/gnome-software --gapplication-service] (owned by unix-user:federico)
Jan 10 07:10:12 pambazo gnome-software[3093]: Failed to get AppStream metadata: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Flatpak system operation DeployAppstream not allowed for user [gs-plugin-error-quark:4]

Jan 10 07:11:16 pambazo polkitd[1120]: Operator of unix-session:2 FAILED to authenticate to gain authorization for action org.freedesktop.Flatpak.runtime-update for system-bus-name::1.94 [/usr/bin/gnome-software --gapplication-service] (owned by unix-user:federico)
Jan 10 07:11:16 pambazo gnome-software[3093]: failed to call gs_plugin_refresh on flatpak: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Flatpak system operation Deploy not allowed for user

For regular desktop machines, I think we should allow Flatpak to update its repositories without prompting.
Comment 1 Frederic Crozat 2018-01-10 14:16:01 UTC
It looks like https://bugzilla.suse.com/show_bug.cgi?id=1012961 was not fully fixed..

Maybe we should reopen it..
Comment 2 Frederic Crozat 2018-10-15 09:39:40 UTC
Is it still valid for TW ? I think https://build.opensuse.org/request/show/536520 fixes it.
Comment 3 Federico Mena Quintero 2018-10-19 10:24:48 UTC
I just updated polkit-default-privs; let me see if I can reproduce the bug...
Comment 4 Frederic Crozat 2018-10-22 09:37:22 UTC
(In reply to Federico Mena Quintero from comment #3)
> I just updated polkit-default-privs; let me see if I can reproduce the bug...

I think it is more related to http://bugzilla.suse.com/show_bug.cgi?id=984817
Comment 5 Federico Mena Quintero 2018-10-23 17:09:58 UTC
After the update to polkit-default-privs, I'm not getting random password prompts anymore.  Consider this fixed.