Bug 1075375 - Firefox fails to connect to proxy when using a socks proxy
Firefox fails to connect to proxy when using a socks proxy
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Firefox
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-10 13:21 UTC by Cédric Bellegarde
Modified: 2018-01-11 10:31 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Bellegarde 2018-01-10 13:21:22 UTC
When configuring a proxy in GNOME settings, Firefox is not using it. Works ok with Chromium.

As it works on ArchLinux and Fedora, I guess it due to this patch.

Yast is not installed on my system.
Comment 1 Wolfgang Rosenauer 2018-01-11 09:25:31 UTC
I'm not sure if Arch and/or Fedora is compiling Firefox with the same options though.
If you can easily compare please look at about:buildconfig and see if they use --enable-libproxy which is what we are doing.

Assuming that libproxy support is still working correctly in Firefox please check on your system via a terminal under Gnome:
zypper in libproxy-tools
proxy http://www.mozilla.org
and see what it returns.
It should reflect what you have set in the Gnome settings as proxy.
Comment 2 Cédric Bellegarde 2018-01-11 09:40:25 UTC
ArchLinux does not seems to use libproxy. Fedora too (after reading the spec file).

BTW:
proxy http://www.mozilla.org
socks://localhost:8080

And maybe the issue is here, because python pip command too does not like the way libproxy set socks URI, version is missing, it should be socks4:// or socks5://.

As Firefox needs version too (in settings), maybe the issue is here?
Comment 3 Wolfgang Rosenauer 2018-01-11 09:44:41 UTC
I never used a socks proxy so I cannot tell if it ever worked or if anything changed.
@dimstar, any comment on the socks versioning part?
Comment 4 Cédric Bellegarde 2018-01-11 10:17:42 UTC
Not related to versionning, I patched libproxy to return socks4:// but does not fix firefox issue.
Comment 5 Cédric Bellegarde 2018-01-11 10:21:11 UTC
Here firefox messsage, so it knows a proxy exists but fails to use it, directly setting socks proxy in firefox works.

Unable to find the proxy server

Firefox is configured to use a proxy server that can’t be found.

    Check the proxy settings to make sure that they are correct.
    Check to make sure your computer has a working network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.
Comment 6 Cédric Bellegarde 2018-01-11 10:30:42 UTC
Ok, closing this one. After playing with Firefox settings, it works again... So I guess Firefox prefs.js was broken in some way. Maybe related to my migration from ArchLinux to Fedora to OpenSUSE with same homedir.

Sorry for noise.
Comment 7 Wolfgang Rosenauer 2018-01-11 10:31:45 UTC
thanks for verifying