Bug 1075329 - openSUSE:Factory/rebootmgr fails to build since json-c update
openSUSE:Factory/rebootmgr fails to build since json-c update
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P1 - Urgent : Major (vote)
: ---
Assigned To: Kubic Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-10 08:42 UTC by Dominique Leuenberger
Modified: 2018-01-10 09:50 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-01-10 08:42:44 UTC
json-c has been updated to version 0.13 on Jan 09 2017

This in turn breaks rebootmgr from building - and this causes the Kubic DVD to be unresolvable

A fix is urgently needed (no snapshot build can finish) - or json-c needs to be reverted (once rebootmgr builds again, I'll promote it to ring2, so it would be seen pre-integration as well; Kubic staging tests are still missing unfortunately)
Comment 1 Thorsten Kukuk 2018-01-10 09:03:57 UTC
Ok, the problem is -Werror, I removed that now.
Else it's comparisation between unsigned and signed, what in this case doesn't matter, since we will never reach the end of the signed 64bit integer scope.

Updated package is on the way.
Comment 2 Dominique Leuenberger 2018-01-10 09:07:31 UTC
Thanks Thorsten

The change in source would be something like

#if JSON_C_VERSION_NUM >= (( 0 << 16) | (13 << 8))
          size_t idx;
#else
          int64_t idx;
#endif

(I found 3 occurences of size_t idx so far)
Comment 3 Thorsten Kukuk 2018-01-10 09:11:56 UTC
Always use u_int64_t and remove -Werror, don't make the code too complex ;)
Comment 4 Swamp Workflow Management 2018-01-10 09:50:06 UTC
This is an autogenerated message for OBS integration:
This bug (1075329) was mentioned in
https://build.opensuse.org/request/show/563221 Factory / rebootmgr