Bug 1075157 - xset hangs when access to display server is refused
xset hangs when access to display server is refused
Status: RESOLVED DUPLICATE of bug 1073996
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-09 09:39 UTC by Howard Guo
Modified: 2018-01-09 10:05 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Howard Guo 2018-01-09 09:39:55 UTC
In the latest tumbleweed snapshot, xset appears to hang in an infinite loop with message "no protocol specified" when it is invoked to operate on a display server it isn't authorised to.

For example, login to desktop as user howard, and then enter root shell and run "xset r rate 175 35", and observe that the command never returns while printing out the error message. The issue disappears after user howard uses "xhost +" to grant root access to display server.

The issue was not observed in the 2017-12-06 snapshot of tumbleweed.
Comment 1 Michal Srb 2018-01-09 10:05:48 UTC
It was a bug in libxcb. Fix is on the way to Tumbleweed.

*** This bug has been marked as a duplicate of bug 1073996 ***