Bug 1075033 - Can't access guest VMs over vboxnet0 anymore
Can't access guest VMs over vboxnet0 anymore
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Larry Finger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-08 15:11 UTC by Andreas Schneider
Modified: 2018-01-08 19:29 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2018-01-08 15:11:15 UTC
I've configured a host-only network in virtualbox which creates vboxnet0. I'm not able to login to VM guests using ssh anymore. There is no traffic going to the guest from the host at all. wireshark doesn't show a single packet.
If I open a browser in the guest I can see it successfully connecting to the internet (vboxnet0 is masqueraded on to the internet).

This worked flawlessly before.

virtualbox-5.1.30-8.4.x86_64
virtualbox-host-kmp-default-5.1.30_k4.14.11_1-8.4.x86_64

What prevents network traffic from my host to the guest network?
Comment 1 Larry Finger 2018-01-08 18:33:19 UTC
I had not used host-only previously, but I got it to work after some effort. All my problems were with getting the VirtualBox internal DHCP server configured.

First record the IP for vboxnet0 in the host. (192.168.56.1 for me.)

You need the correct VirtualBox Extensions installed on the host.

Using the GUI, check File=>Preferences=>Network. Make sure that NatNetworks are not active. Then edit your host-only network (vboxnet0) and verify that the DHCP server shows the correct information. In particular, verify that the IP address matches that of the host's vboxnet0.

Boot one of your VMs. Once it gets an IP, does it match the network for the host vboxnet0? (192.168.56.10 for me.) If not, you have a problem in one of the steps above. Once you get the IP correct, you should have networking between VMs and the host.
Comment 2 Andreas Schneider 2018-01-08 18:50:00 UTC
I have my own DNS (dnsmasq) running on my host, it listens on vboxnet0. All my guests correctly get an IP address from dnsmasq. However the strange thing is that something prevents that I can access the guest VMs from my host system. It worked just fine for years but stopped working out of the blue.

Maybe it is and issue with 5.1.30 and Kernel 4.14. I see that 5.2.4 is on the way to factory.
Comment 3 Larry Finger 2018-01-08 19:04:48 UTC
I tested with 5.1.30 AND 5.2.4. Both work with the internal DHCP server. My guests were running kernel 4.14.11. The host is running 4.15-rc7.

Check the routing tables to verify that they agree with the IP assignments. In particular, is the rule for routing from vboxnet0 correct?
Comment 4 Andreas Schneider 2018-01-08 19:27:22 UTC
magrathea:~ # ip route show 
default via 192.168.178.1 dev eno1 proto static metric 100 
192.168.100.0/24 dev vboxnet0 proto kernel scope link src 192.168.100.1 linkdown

The strange thing is that everything works in one direction. I can ssh from the guest to the host, but not from the host to the guest.

So something on the host prevents me from accessing vboxnet0.
Comment 5 Andreas Schneider 2018-01-08 19:29:33 UTC
I've shut down the interface manually now. Then I started it again and I have access now.

I don't understand it. Closing the bug. Thanks for the help.