Bug 1075018 - [4.14.12] PANIC: double fault, error_code: 0x0
[4.14.12] PANIC: double fault, error_code: 0x0
Status: RESOLVED DUPLICATE of bug 1074869
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks: 1075183
  Show dependency treegraph
 
Reported: 2018-01-08 13:37 UTC by Andreas Schwab
Modified: 2018-01-09 13:43 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schwab 2018-01-08 13:37:49 UTC
Building a package for i586 in KVM with the latest kernel-obs-build.x86_64 often fails with a double fault.  A lot of packages in ibs:SUSE:Factory:Head are failing due to this.

[  396s] [  382.916764] PANIC: double fault, error_code: 0x0
[  396s] [  382.917722] Kernel panic - not syncing: Machine halted.
[  396s] [  382.918642] CPU: 6 PID: 21400 Comm: rpm Not tainted 4.14.12-1-default #1
[  396s] [  382.919827] Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS 1.0.0-prebuilt.qemu-project.org 04/01/2014
[  396s] [  382.920045] Call Trace:
[  396s] [  382.920045]  <#DF>
[  396s] [  382.920045]  dump_stack+0x5c/0x85
[  396s] [  382.920045]  panic+0xd5/0x232
[  396s] [  382.920045]  df_debug+0x29/0x30
[  396s] [  382.920045]  do_double_fault+0xaa/0x140
[  396s] [  382.920045]  double_fault+0x22/0x30
[  396s] [  382.920045]  ? entry_SYSCALL_compat+0x83/0x136
[  396s] [  382.920045]  </#DF>
[  396s] [  382.920045] Kernel Offset: 0x2a000000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)

Note that openSUSE:Factory is using kernel-obs-build.i586 for building, thus does see this issue.
Comment 1 Takashi Iwai 2018-01-08 14:02:02 UTC
Possibly the breakage due to PTI thingy?
Comment 2 Borislav Petkov 2018-01-08 15:16:16 UTC
Does it happen if you boot that kernel with "pti=off" ?
Comment 3 Takashi Iwai 2018-01-08 15:18:50 UTC
AFAIU, it seems happening only spontaneously during building some packages with 32bit compat mode with the latest TW kernel, so it's hard to reproduce reliably.

BTW, the similar double-fault was reported for WINE 32bit, bsc#1074869.
Comment 4 Andreas Schwab 2018-01-08 15:27:52 UTC
I cannot control the kernel parameters of the build process.
Comment 5 Andreas Schwab 2018-01-09 11:39:17 UTC
The failure can also be seen in the OBS project home:Andreas_Schwab:test.
Comment 6 Jiri Slaby 2018-01-09 13:43:21 UTC
.

*** This bug has been marked as a duplicate of bug 1074869 ***