Bug 1074924 - btrfs process makes system unresponsive
btrfs process makes system unresponsive
Status: RESOLVED DUPLICATE of bug 1063638
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-07 23:35 UTC by Thomas König
Modified: 2018-02-07 12:17 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas König 2018-01-07 23:35:53 UTC
A running btrfs process is currently making my system almost unresponsive.
It is running at 100% every now and then, and there is heavy disk
activity. In the meantime, even a simple cklick takes many seconds
for the system to react.

I have added the output of "mount" in case this helps anybody...

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)                                                                                                                                                                                   
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)                                                                                                                                                                                    
devtmpfs on /dev type devtmpfs (rw,nosuid,size=2014476k,nr_inodes=503619,mode=755)                                                                                                                                                           
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)                                                                                                                                                         
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)                                                                                                                                                                                               
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)                                                                                                                                                       
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)                                                                                                                                                                                          
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)                                                                                                                                                                         
cgroup on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime)                                                                                                                                                              
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)                                                                                                                                            
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)                                                                                                                                                                       
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)                                                                                                                                                         
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)                                                                                                                                                             
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)                                                                                                                                                         
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
/dev/sda5 on / type btrfs (rw,relatime,space_cache,subvolid=614,subvol=/@/.snapshots/275/snapshot)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=32,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=14425)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda5 on /var/cache type btrfs (rw,relatime,space_cache,subvolid=266,subvol=/@/var/cache)
/dev/sda5 on /.snapshots type btrfs (rw,relatime,space_cache,subvolid=258,subvol=/@/.snapshots)
/dev/sda5 on /var/opt type btrfs (rw,relatime,space_cache,subvolid=276,subvol=/@/var/opt)
/dev/sda5 on /var/lib/mailman type btrfs (rw,relatime,space_cache,subvolid=270,subvol=/@/var/lib/mailman)
/dev/sda5 on /var/lib/mariadb type btrfs (rw,relatime,space_cache,subvolid=271,subvol=/@/var/lib/mariadb)
/dev/sda5 on /var/lib/mysql type btrfs (rw,relatime,space_cache,subvolid=272,subvol=/@/var/lib/mysql)
/dev/sda5 on /var/lib/named type btrfs (rw,relatime,space_cache,subvolid=273,subvol=/@/var/lib/named)
/dev/sda5 on /var/lib/machines type btrfs (rw,relatime,space_cache,subvolid=269,subvol=/@/var/lib/machines)
/dev/sda5 on /boot/grub2/x86_64-efi type btrfs (rw,relatime,space_cache,subvolid=261,subvol=/@/boot/grub2/x86_64-efi)
/dev/sda5 on /boot/grub2/i386-pc type btrfs (rw,relatime,space_cache,subvolid=260,subvol=/@/boot/grub2/i386-pc)
/dev/sda5 on /tmp type btrfs (rw,relatime,space_cache,subvolid=264,subvol=/@/tmp)
/dev/sda5 on /srv type btrfs (rw,relatime,space_cache,subvolid=263,subvol=/@/srv)
/dev/sda5 on /var/lib/libvirt/images type btrfs (rw,relatime,space_cache,subvolid=268,subvol=/@/var/lib/libvirt/images)
/dev/sda5 on /var/lib/pgsql type btrfs (rw,relatime,space_cache,subvolid=274,subvol=/@/var/lib/pgsql)
/dev/sda5 on /opt type btrfs (rw,relatime,space_cache,subvolid=262,subvol=/@/opt)
/dev/sda5 on /usr/local type btrfs (rw,relatime,space_cache,subvolid=265,subvol=/@/usr/local)
/dev/sda5 on /var/tmp type btrfs (rw,relatime,space_cache,subvolid=278,subvol=/@/var/tmp)
/dev/sda5 on /var/log type btrfs (rw,relatime,space_cache,subvolid=275,subvol=/@/var/log)
/dev/sda5 on /var/crash type btrfs (rw,relatime,space_cache,subvolid=267,subvol=/@/var/crash)
/dev/sda5 on /var/spool type btrfs (rw,relatime,space_cache,subvolid=277,subvol=/@/var/spool)
/dev/sda4 on /home type ext4 (rw,relatime,data=ordered)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=404268k,mode=700,uid=1000,gid=100)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
tracefs on /sys/kernel/debug/tracing type tracefs (rw,relatime)
Comment 1 Libor Pechacek 2018-02-07 12:17:09 UTC
From limited information in comment #0 I guess this is duplicate of bug 1063638.

*** This bug has been marked as a duplicate of bug 1063638 ***