Bug 1074921 - latest tumbleweed kernel 4.14.11 crashes upon starting Steam client
latest tumbleweed kernel 4.14.11 crashes upon starting Steam client
Status: RESOLVED DUPLICATE of bug 1074869
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks: 1075183
  Show dependency treegraph
 
Reported: 2018-01-07 20:10 UTC by Daniel Bischof
Modified: 2018-01-09 13:43 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
jslaby: needinfo? (dbischof)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bischof 2018-01-07 20:10:41 UTC
Upgraded to Tumbleweed 20180104 today:
---
2018-01-07 10:52:59|command|root@xxx|'zypper' 'dup'|
2018-01-07 10:53:10|install|kernel-firmware|20180104-1.1|noarch||tumbleweed-oss|f5c6e36385feae311fcf22196420d71807883457|
2018-01-07 10:53:10|install|ucode-amd|20180104-1.1|noarch||tumbleweed-oss|6bbd2096485c7ff3faf3b7c13520672136b6be82|
2018-01-07 10:53:10|install|openSUSE-release-ftp|20180104-1.2|x86_64||tumbleweed-oss|cfce8a63edcf75ee5107ff034d09e2c296d9a51c|
2018-01-07 10:53:11|install|ucode-intel|20171117-2.1|x86_64||tumbleweed-oss|0ad35d041a7fdf358373321c06e3b7035a775ac5|
2018-01-07 10:53:13|install|openSUSE-release|20180104-1.2|x86_64||tumbleweed-oss|82b01492acc9fcfd90e73a72e055e100a5c842cc|
---

No other changes made. Upon starting the Steam client my machine just freezes:
---
Running Steam on opensuse 20180104 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
---

Hard poweroff required, not even Alt-SysReq worked. Nothing in the logs.
If I reboot using the previous kernel 4.14.9, Steam works fine.

/proc/cpuinfo:
---
vendor_id       : AuthenticAMD
cpu family      : 21
model           : 48
model name      : AMD A8-7600 Radeon R7, 10 Compute Cores 4C+6G
stepping        : 1
microcode       : 0x6003106
cpu MHz         : 1400.000
cache size      : 2048 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 2
apicid          : 16
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb bpext ptsc cpb hw_pstate vmmcall fsgsbase bmi1 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold overflow_recov
bugs            : fxsave_leak sysret_ss_attrs null_seg
bogomips        : 6200.19
TLB size        : 1536 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro [13]
---
Comment 1 t neo 2018-01-08 02:17:38 UTC
I'm having the same issue. I have the same APU.
Comment 2 Daniel Bischof 2018-01-08 09:03:14 UTC
Though the above list of packages installed lacks the actual kernel package, both the microcode and kernel packages have been installed. Should be clear from the context, just to make sure.
Comment 3 Takashi Iwai 2018-01-08 14:35:17 UTC
Could you check whether booting with nopti option makes thing working?
Comment 4 Daniel Bischof 2018-01-08 18:14:39 UTC
Positive. When using "nopti" kernel option, the Steam client works with Kernel 4.14.11.
Comment 5 Jiri Slaby 2018-01-09 13:13:27 UTC
Could you check with 4.14.12 from Kernel:stable?
Comment 6 Jiri Slaby 2018-01-09 13:43:11 UTC
.

*** This bug has been marked as a duplicate of bug 1074869 ***