Bug 1074790 - Exclusion of syntax.vim in package gvim causing error
Exclusion of syntax.vim in package gvim causing error
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
All openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Ismail Dönmez
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-05 10:22 UTC by Dany Marcoux
Modified: 2018-01-24 12:33 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dany Marcoux 2018-01-05 10:22:45 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build Identifier: 

Whenever launching gvim, I get the following error:

E484: Can't open file /usr/share/vim/vim80/syntax/syntax.vim

The file indeed doesn't exist since it is excluded in the spec file[1] at the line 471:

%exclude %{_datadir}/vim/%{VIM_SUBDIR}/syntax/syntax.vim

[1] https://build.opensuse.org/package/view_file/openSUSE:Factory/vim/vim.spec?expand=1

Reproducible: Always

Steps to Reproduce:
1. Install gvim
2. Launch gvim
3. Error happens
Comment 1 Dany Marcoux 2018-01-17 11:12:12 UTC
Request to fix this: https://build.opensuse.org/request/show/566596
Comment 2 Ismail Dönmez 2018-01-17 11:17:56 UTC
(In reply to Dany Marcoux from comment #1)
> Request to fix this: https://build.opensuse.org/request/show/566596

This needs some thinking since vim needs this file too.
Comment 3 Dany Marcoux 2018-01-18 19:54:51 UTC
The different scenarios are the following:

1. Install gvim. vim-data is installed as a dependency. vim is not installed. syntax.vim is missing, so there is the error when launching gvim:

```
Error detected while processing function plug#end:
line   86:
E484: Can't open file /usr/share/vim/vim80/syntax/syntax.vim
Error detected while processing /home/dany/.vimrc:
line  134:
E484: Can't open file /usr/share/vim/vim80/syntax/syntax.vim
Error detected while processing function <SNR>7_set_highlight_colors[27]..<SNR>7_add_to_highlight_group:
line    1:
E417: missing argument: guifg=
```

2. Install vim without recommends (so without vim-data). syntax.vim is present, but there still an error when launching vim: 

```
Error detected while processing function <SNR>15_set_highlight_colors[27]..<SNR>15_add_to_highlight_group:
line    1:
E417: missing argument: ctermfg=
```

3. Install vim with recommends (so with vim-data). syntax.vim is present and there is no error when launching vim. gvim is not installed.

4. Install gvim (vim-data is included) and vim. syntax.vim is present and there is no error when launching vim/gvim.

To have no error at all, one needs vim and vim-data. vim could require vim-data just like gvim does and then vim-data take cares of syntax.vim. This way, all gvim/vim users are taken care of.
Comment 4 Ismail Dönmez 2018-01-19 10:51:39 UTC
But there is also the problem that container guys don't want vim-data dependency (due to size considerations).
Comment 5 Swamp Workflow Management 2018-01-24 12:30:08 UTC
This is an autogenerated message for OBS integration:
This bug (1074790) was mentioned in
https://build.opensuse.org/request/show/568886 Factory / vim
Comment 6 Dany Marcoux 2018-01-24 12:33:51 UTC
Request accepted: https://build.opensuse.org/request/show/566596