Bug 1074406 - amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got ...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-03 00:00 UTC by Matthias Eliasson
Modified: 2018-11-24 23:49 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (elimat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Eliasson 2018-01-03 00:00:34 UTC
I get the message "amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff" during boot. This message interrupt the graphicl boot. Also some times my computer gets froozen during boot and stop respond to keybaord key press and I have to do a hard reset.

I have tested with other distro (Solus) without this issue and they are on the same kernel tree (4.14.x)

sudo lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/580] (rev c7)

uname -a
Linux jarvis 4.14.9-1-default #1 SMP PREEMPT Mon Dec 25 15:42:48 UTC 2017 (9423ca2) x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a
LSB Version:	n/a
Distributor ID:	openSUSE
Description:	openSUSE Tumbleweed
Release:	20171231
Codename:	n/a

found below from arch linux wiki:

Also, since kernel 4.13, adding the amdgpu.si_support=1 radeon.si_support=0 or amdgpu.cik_support=1 radeon.cik_support=0 kernel parameter is required. Otherwise, AMDGPU will not start and you will end up with either radeon being used instead or the display being frozen during the boot.

ref: https://wiki.archlinux.org/index.php/AMDGPU

Sounds alot like my issues.
Comment 1 Takashi Iwai 2018-01-03 08:55:24 UTC
Is this a regression from earlier kernels (e.g. 4.13.x)?
Also, try to boot with nomodeset option to check whether the freeze is the graphics driver issue.

And, did you check whether si_support and cik_support options have influence on the behavior on your machine?
Comment 2 Matthias Eliasson 2018-01-13 16:06:28 UTC
The actual message have been in 4.13 kernel branch as well. But earlier I have just got this message during boot but never had any actual issues that it was freezing during boot. This issue is new in 4.14 kernel branch.

I will add nomodeset to kernel parameter to see if this issue is removed. 

About your third question I am not sure how to test this. Do you have any examples?
Comment 3 Matthias Eliasson 2018-02-03 13:11:39 UTC
the message "amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff" was not showing on the new 4.15 kernel but unfortunatley I did not get futher in the boot process of 4.15 kernel which I have reported in
#1079217
Comment 4 Jiri Slaby 2018-06-16 12:11:02 UTC
DOes this still happen with 4.17?
Comment 5 Matthias Eliasson 2018-06-17 21:08:54 UTC
No, I have not seen this error during 4.16.12 or 4.17

Feel free to close this issue.

Thanks.
Comment 6 Jiri Slaby 2018-06-18 05:30:24 UTC
thanks
Comment 7 Ulrich Windl 2018-11-24 23:49:01 UTC
The issue is there in Leap 15.0 (4.12.14-lp150.12.25-default), too (seen for an ASRock Radeon RX560 4GB).