Bug 1074368 - lp and lpr have no default destination
lp and lpr have no default destination
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Printing
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Johannes Meixner
Johannes Meixner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-02 17:08 UTC by Thomas König
Modified: 2019-05-14 08:18 UTC (History)
0 users

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas König 2018-01-02 17:08:13 UTC
I have a remote printer, accessible via TCP, which is recognized.
I have also set this as the standard printer using yast.

However, lpr does not seem to recognize that, running the command
yields

lpr: Error - no default destination available.

This is with a current Tumbleweed installation with CUPS.

If there is any other data you need, I'll be happy to supply it.
Comment 1 Johannes Meixner 2018-03-08 13:11:04 UTC
There is no such thing as "THE" default print queue.

There is even no such thing as a system default print queue.

See
https://en.opensuse.org/SDB:Print_Settings_with_CUPS

See also "Default Queue" at
https://en.opensuse.org/YaST_Printer
Comment 2 Johannes Meixner 2019-05-14 08:18:24 UTC
I assume it was sufficiently aswered by coment #1
so that the problem described is not a bug, cf.
https://bugzilla.suse.com/page.cgi?id=status_resolution_matrix.html