Bug 1074361 - No sound with pulseaudio and huge CPU usage
No sound with pulseaudio and huge CPU usage
Status: RESOLVED DUPLICATE of bug 1073996
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Sound
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-02 16:26 UTC by Fabian Niepelt
Modified: 2018-01-03 07:51 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Strace of pulseaudio strace (1.88 KB, text/plain)
2018-01-02 16:26 UTC, Fabian Niepelt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Niepelt 2018-01-02 16:26:59 UTC
Created attachment 754552 [details]
Strace of pulseaudio strace

Hello,

after updating to snapshot 20171213 or later, I don't have sound anymore. Rollbacking to a snapshot before that one restores sound.
`top` reports high CPU usage for pulseaudio (~50%) and X11 (~95 to 100%). Pulseaudio cannot be killed except with a SIGKILL at which point X11 calms down too.

`strace` on the running pulseaudio process seems to indicate that it is in some kind of loop (see attachment).

`journalct -t pulseaudio` yields the following:
Jan 02 13:51:47 linux-0yez pulseaudio[2620]: [pulseaudio] alsa-mixer.c: Volume element Speaker has 8 channels. That's too much! I can't handle that!
Jan 02 13:51:47 linux-0yez pulseaudio[2620]: [pulseaudio] alsa-mixer.c: Volume element Speaker has 8 channels. That's too much! I can't handle that!
Jan 02 13:51:47 linux-0yez pulseaudio[2620]: [pulseaudio] alsa-mixer.c: Volume element Speaker has 8 channels. That's too much! I can't handle that!
Jan 02 13:51:47 linux-0yez pulseaudio[2620]: [pulseaudio] alsa-mixer.c: Volume element PCM has 8 channels. That's too much! I can't handle that!
Jan 02 13:51:47 linux-0yez pulseaudio[2620]: [pulseaudio] alsa-mixer.c: Volume element PCM has 8 channels. That's too much! I can't handle that!
Jan 02 13:51:47 linux-0yez pulseaudio[2620]: [pulseaudio] alsa-mixer.c: Volume element PCM has 8 channels. That's too much! I can't handle that!
Jan 02 13:51:47 linux-0yez pulseaudio[2620]: [pulseaudio] alsa-mixer.c: Volume element PCM has 8 channels. That's too much! I can't handle that!
Jan 02 13:51:48 linux-0yez pulseaudio[2620]: [pulseaudio] x11wrap.c: XOpenDisplay() failed
Jan 02 13:51:48 linux-0yez pulseaudio[2620]: [pulseaudio] module.c: Failed to load module "module-x11-publish" (argument: "display=:0"): initialization failed.
Jan 02 13:52:12 linux-0yez pulseaudio[2620]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out

":0" is the correct display (`echo $DISPLAY` in konsole also shows ":0").

Manually starting pulseaudio with `/usr/bin/pulseaudio --start --log-target=syslog` after killing it does *not* reproduce the error.

The error occurs on two different systems of mine (others don't use oS) with no overlapping hardware so far.

Greetings
Fabian
Comment 1 Takashi Iwai 2018-01-02 16:30:52 UTC
Could you try to update only pulseaudio (and related) packages?
I'd like to know whether it's an issue of PA itself or anything else.
Comment 2 Fabian Niepelt 2018-01-02 17:09:41 UTC
(In reply to Takashi Iwai from comment #1)
> Could you try to update only pulseaudio (and related) packages?
> I'd like to know whether it's an issue of PA itself or anything else.

Thanks for the quick answer. There hasn't been a PA update in any snapshots since then so it's probably another package. I'm trying to single out the package update that introduced this bug for me, but there are over a thousand package updates I'm sifting through so it could take a while.
Comment 3 Fabian Niepelt 2018-01-02 17:57:36 UTC
(In reply to Takashi Iwai from comment #1)
> Could you try to update only pulseaudio (and related) packages?
> I'd like to know whether it's an issue of PA itself or anything else.

I found the culprit in libxcb1. It also seems to already be reported in #1073996.

This bug could be closed as a duplicate if you don't want it hanging around. I'll add myself to the CC of the other bug.
Comment 4 Takashi Iwai 2018-01-03 07:51:56 UTC
Thanks for spotting out!  Let's close as dup.

*** This bug has been marked as a duplicate of bug 1073996 ***