Bug 1074272 - Firefox crashes when file upload dialog gets canceled
Firefox crashes when file upload dialog gets canceled
Status: RESOLVED DUPLICATE of bug 1069962
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Firefox
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-01 21:52 UTC by Fabian Vogt
Modified: 2018-01-01 22:19 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-01-01 21:52:47 UTC
Same as bug 1069962.

See also https://github.com/openSUSE/kmozillahelper/issues/18.

Looks like https://www.rosenauer.org/hg/mozilla/rev/932b3ad009d5 reverted https://www.rosenauer.org/hg/mozilla/rev/17fe7b84cafe again:
NS_ADDREF_THIS(); and NS_RELEASE_THIS(); are gone.
Comment 1 Wolfgang Rosenauer 2018-01-01 22:10:29 UTC
As can be seen in the other bug I already tried with those reapplied and it is still crashing.

Any ideas appreciated.
Comment 2 Fabian Vogt 2018-01-01 22:19:50 UTC
(In reply to Wolfgang Rosenauer from comment #1)
> As can be seen in the other bug I already tried with those reapplied and it
> is still crashing.
> 
> Any ideas appreciated.

Which other bug? bug 1069962? I can try some ideas, but with the incredibly long build time of firefox that can take a while.

I'll close this as a duplicate now, I thought 1069962 was the one which got closed a while ago as it has the same title...

*** This bug has been marked as a duplicate of bug 1069962 ***