Bug 1074269 - [Build 20171231] Invalid icon theme
[Build 20171231] Invalid icon theme
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Xfce
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Florian Koch
E-mail List
http://openqa.opensuse.org/tests/5718...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-01 20:28 UTC by Dominique Leuenberger
Modified: 2021-06-21 08:50 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
screenshot after fixing index.theme (491.74 KB, image/png)
2018-01-02 19:12 UTC, Stefan Seyfried
Details
Screenshot after changing to Adwaita (361.99 KB, image/png)
2018-01-03 16:57 UTC, Florian Koch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-01-01 20:28:45 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-create_hdd_xfce@64bit fails in
[first_boot](http://openqa.opensuse.org/tests/571886/modules/first_boot/steps/15)


## Reproducible

Fails since (at least) Build [20171231](http://openqa.opensuse.org/tests/571678)


## Expected result

Last good: [20171230](http://openqa.opensuse.org/tests/571008) (or more recent)


## Further details

Always latest result in this scenario: [latest](http://openqa.opensuse.org/tests/latest?machine=64bit&version=Tumbleweed&test=create_hdd_xfce&flavor=DVD&distri=opensuse&arch=x86_64)

# More informataion

The icon theme was switched to 'adwaita', as asked by me to be investigated if possible. But apparenlty nobody ever tried to run it before submitting it into TW... the result is now missing icons.

I reverted xfce-branding in openSUSE:Factory back to gnome-icon-theme's state, to get this back running (you will need to investigate if this change is doable or not based on the devel project... if not doable, don't do it just because I propose it!)
Comment 1 Dominique Leuenberger 2018-01-01 20:31:15 UTC
The SR that introduced the change was https://build.opensuse.org/request/show/560759
Comment 2 Stefan Seyfried 2018-01-02 18:42:40 UTC
I'm just test-installing right now, but I guess the problem is, that the diff in sr 560759 was:

@@ -1,7 +1,7 @@
 [Icon Theme]
 Name=openSUSE-Xfce
 Comment=openSUSE Xfce Default Icon Theme
-Inherits=gnome
+Inherits=adwaita
 Example=folder
 

but...
The directories are named:
/usr/share/icons/Adwaita/
/usr/share/icons/gnome/

I *guess* that the diff would need to be
-...
+Inherits=Adwaita

I'll test this once my VM is installed and report back.
Comment 3 Florian Koch 2018-01-02 18:56:30 UTC
I apologize for the trouble, next time i test the change better. 
(i think my icon cache was the "problem")
From now on i always use a clean install...

I was not aware that this goes straight to Factory.....

@Stefan Seyfried thx for checking
Comment 4 Stefan Seyfried 2018-01-02 19:12:28 UTC
Created attachment 754561 [details]
screenshot after fixing index.theme

My guess was right. SR#561181 is on its way to Factory.
Not that this will still change the look slightly, so the openQA needles might need updating (see screenshot, the HDD icon looks different and the DVD icon has no DVD logo on it)
Comment 5 Swamp Workflow Management 2018-01-02 19:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1074269) was mentioned in
https://build.opensuse.org/request/show/561181 Factory / xfce4-branding-openSUSE
Comment 6 Dominique Leuenberger 2018-01-03 08:23:48 UTC
(In reply to Stefan Seyfried from comment #4)
> Created attachment 754561 [details]
> screenshot after fixing index.theme
> 
> My guess was right. SR#561181 is on its way to Factory.
> Not that this will still change the look slightly, so the openQA needles
> might need updating (see screenshot, the HDD icon looks different and the
> DVD icon has no DVD logo on it)

Thanks - that does look better (at least Trash has an icon again)

Can you please also check that when opening the application launcher, things look better again? (that looked kinda weird too in that snapshot)

Other than that, I'll be happy to have 10MB more space (new kernel will be eating this up very quickly...(
Comment 7 Florian Koch 2018-01-03 16:53:22 UTC
@Dominique Leuenberger 

i have installed the TW Snapshot 20180101 in a VM

Then i removed all gnome-icon-theme* rpms and the /usr/share/icons/gnome folder
Installed xfce4-branding-openSUSE from X11:xfce

After a reboot it looks good
Panel has Icons, Thunar, and the Application Launcher also
Comment 8 Florian Koch 2018-01-03 16:57:56 UTC
Created attachment 754713 [details]
Screenshot after changing to Adwaita
Comment 9 Dominique Leuenberger 2018-01-03 17:07:21 UTC
Thanks for testing this new version (before getting it into a new TW snapshot)

That means 0102 (with the latest diff) should be fine (some icons will change, which is expected and new needles will be created by me once 0102 reaches openqA)

Thanks all for working so swiftly on a solution
Comment 10 Florian Koch 2018-01-14 13:07:20 UTC
Tested in 20180109
Comment 11 Swamp Workflow Management 2018-11-30 18:30:06 UTC
This is an autogenerated message for OBS integration:
This bug (1074269) was mentioned in
https://build.opensuse.org/request/show/653123 Factory / xfce4-branding-openSUSE
Comment 12 OBSbugzilla Bot 2021-06-21 08:50:06 UTC
This is an autogenerated message for OBS integration:
This bug (1074269) was mentioned in
https://build.opensuse.org/request/show/901100 Factory / xfce4-branding-openSUSE