Bug 1074265 - syntax error in virt-aa-helper AppArmor profile
syntax error in virt-aa-helper AppArmor profile
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Other
Current
Other openSUSE 42.2
: P5 - None : Major (vote)
: ---
Assigned To: Cédric Bosdonnat
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-01 15:24 UTC by Christian Boltz
Modified: 2018-01-03 15:40 UTC (History)
1 user (show)

See Also:
Found By: Beta-Customer
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Boltz 2018-01-01 15:24:33 UTC
/etc/apparmor.d/usr.lib.libvirt.virt-aa-helper contains a syntax error which prevents loading the profile:

  /run/libvirt/**/[sv]d[a-z] r

This line should be

  /run/libvirt/**/[sv]d[a-z] r,

(comma added at the end to fix the syntax)
or even better

  /{,var/}run/libvirt/**/[sv]d[a-z] r,

to also work on systems where /var/run/ is not a symlink to /run/ (like mine).
Comment 1 Cédric Bosdonnat 2018-01-02 16:53:58 UTC
mine
Comment 2 Cédric Bosdonnat 2018-01-03 12:05:28 UTC
Thanks for the heads up.
Fix on its way towards factory and submitted upstream
Comment 3 Swamp Workflow Management 2018-01-03 14:10:05 UTC
This is an autogenerated message for OBS integration:
This bug (1074265) was mentioned in
https://build.opensuse.org/request/show/561346 Factory / libvirt
Comment 4 Swamp Workflow Management 2018-01-03 15:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1074265) was mentioned in
https://build.opensuse.org/request/show/561423 Factory / libvirt