Bug 1074168 - German keyboard not applied
German keyboard not applied
Status: RESOLVED DUPLICATE of bug 1073215
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Basesystem
Leap 15.0
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-28 09:19 UTC by Axel Braun
Modified: 2018-01-09 13:16 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2017-12-28 09:19:02 UTC
Installed Leap 15 Alpha as of 28.12.2017 with german keyboard layout.
Language is set to german, but keyboard layout is still US, although it claims in YaST to be the german layout.
Comment 1 Axel Braun 2017-12-29 09:44:04 UTC
See https://bugzilla.opensuse.org/attachment.cgi?id=754411 for y2logs
Comment 2 Axel Braun 2017-12-29 12:03:04 UTC
apologies, wrong attachment. in comment 1
this is the correct one!
https://bugzilla.opensuse.org/attachment.cgi?id=754423
Comment 3 Josef Reidinger 2017-12-29 14:18:00 UTC
Hi Axel, I expect it is common misunderstanding of keyboard layouts. Do you mean layout in Desktop environment? And if so, does you DE use system keyboard layout or manage it on its own? If the second is case, then it is per user config and something that yast cannot set, as yast manage only system config and it is DE job to manage it per user.
Comment 4 Axel Braun 2017-12-29 14:22:00 UTC
(In reply to Josef Reidinger from comment #3)
> Hi Axel, I expect it is common misunderstanding of keyboard layouts. Do you
> mean layout in Desktop environment? And if so, does you DE use system
> keyboard layout or manage it on its own? If the second is case, then it is
> per user config and something that yast cannot set, as yast manage only
> system config and it is DE job to manage it per user.

Hello Josef,
to be honest - I'm not sure. If I install in german language, right at the bootscreen of the installation media, and during setup I confirm german as keyboard settings, I expect KDE to run a german keyboard layout.
Anything else is just not user friendly....
Comment 5 Josef Reidinger 2017-12-29 14:29:16 UTC
(In reply to Axel Braun from comment #4)
> (In reply to Josef Reidinger from comment #3)
> > Hi Axel, I expect it is common misunderstanding of keyboard layouts. Do you
> > mean layout in Desktop environment? And if so, does you DE use system
> > keyboard layout or manage it on its own? If the second is case, then it is
> > per user config and something that yast cannot set, as yast manage only
> > system config and it is DE job to manage it per user.
> 
> Hello Josef,
> to be honest - I'm not sure. If I install in german language, right at the
> bootscreen of the installation media, and during setup I confirm german as
> keyboard settings, I expect KDE to run a german keyboard layout.
> Anything else is just not user friendly....

agreed. I will mark it as duplicate of already existing bug report for this missing propagate to DE. So we have it in one place.

*** This bug has been marked as a duplicate of bug 1046436 ***
Comment 6 Stefan Dirsch 2018-01-09 13:16:06 UTC

*** This bug has been marked as a duplicate of bug 1073215 ***