Bug 1074160 - Unable to input CJK characters in calibre with fcitx
Unable to input CJK characters in calibre with fcitx
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
x86-64 Other
: P5 - None : Minor (vote)
: ---
Assigned To: Juergen Weigert
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-28 04:30 UTC by JuPing Chan
Modified: 2018-01-08 12:33 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JuPing Chan 2017-12-28 04:30:32 UTC
fcitx does not activate in the calibre search bar. I have encountered this problem with fcitx alone. In the KDE panel the input method on mouseover says "No input window" when it should at least say "Keyboard - English (US)". Attempts to write using the virtual keyboard also fail.
Comment 1 Fabian Vogt 2017-12-29 20:10:56 UTC
Reassigning to calibre maintainers.
Comment 2 Cor Blom 2018-01-07 14:54:59 UTC
I cannot reproduce this. I do see "Keyboard - English (VS)" in Calibre in the fcitx applet in the panel when I hover over it.
Comment 3 JuPing Chan 2018-01-08 09:49:12 UTC
Is it possible that this problem is because of a difference between the repository version of calibre and upstream?

I'm currently using the installation method recommended by upstream which is to install via 

sudo -v && wget -nv -O- https://download.calibre-ebook.com/linux-installer.py | sudo python -c "import sys; main=lambda:sys.stderr.write('Download failed\n'); exec(sys.stdin.read()); main()"

Installing from the repositories yields a plugin error, so I stopped using it.
Comment 4 Cor Blom 2018-01-08 12:33:17 UTC
(In reply to Ju_Ping Chan from comment #3)
> Is it possible that this problem is because of a difference between the
> repository version of calibre and upstream?

Upstream bug is probably still true:

https://bugs.launchpad.net/calibre/+bug/1441032

Try googling it. You cannot be the only one. Maybe someone has found a workaround. I found:

https://www.mobileread.com/forums/showthread.php?t=244887

> Installing from the repositories yields a plugin error, so I stopped using
> it.

I don't get any errors, but you can try a bugreport.

I'm closing this bug, because it is not about our calibre.