Bug 1073691 - Inserting a removable disc in an USB 3 port does not show the device
Inserting a removable disc in an USB 3 port does not show the device
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Oliver Neukum
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-20 13:31 UTC by Freek de Kruijf
Modified: 2018-01-24 15:21 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Freek de Kruijf 2017-12-20 13:31:19 UTC
Inserting a removable disc in an USB 3 port does not show the device.
Only after entering the line:

options usb-storage quirks=4971:1015:u

in /etc/modprobe.d/99-local.conf

the device shows in the widget for removable devices, and I can mount it.

the numbers 4971:1015 are specific for my device, and are shown for this device in the output of lsusb
Comment 1 Michal Marek 2018-01-24 12:46:55 UTC
Hi Oliver, I guess this one is for you.
Comment 2 Oliver Neukum 2018-01-24 13:01:18 UTC
Please provide dmesg
Comment 3 Freek de Kruijf 2018-01-24 15:01:55 UTC
Below is the part got after inserting the USB disk in the USB 3.0 port with the file /etc/modprobe.d/99-local.conf in place.

[  500.751728] usb usb6-port3: disabled by hub (EMI?), re-enabling...
[  500.751740] usb 6-3: USB disconnect, device number 2
[  501.093113] usb 6-3: new low-speed USB device number 4 using ohci-pci
[  511.676673] usb 6-3: New USB device found, idVendor=0001, idProduct=0000
[  511.676681] usb 6-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  511.676685] usb 6-3: Product: MEC0002
[  511.676689] usb 6-3: Manufacturer: MEC
[  511.700678] hid-generic 0003:0001:0000.0006: hiddev98,hidraw4: USB HID v1.00 Device [MEC MEC0002] on usb-0000:00:12.0-3/input0
[  515.513251] usb 2-2: new SuperSpeed USB device number 2 using xhci_hcd
[  515.536915] usb 2-2: New USB device found, idVendor=4971, idProduct=1015
[  515.536922] usb 2-2: New USB device strings: Mfr=10, Product=11, SerialNumber=3
[  515.536927] usb 2-2: Product: Touro Desk 3.0
[  515.536930] usb 2-2: Manufacturer: HitachiGST
[  515.536934] usb 2-2: SerialNumber: 31001206050000001701
[  515.537918] usb-storage 2-2:1.0: USB Mass Storage device detected
[  515.542238] usb-storage 2-2:1.0: Quirks match for vid 4971 pid 1015: 800000
[  515.542311] scsi host9: usb-storage 2-2:1.0
[  518.580899] scsi 9:0:0:0: Direct-Access     HitachiG ST               0000 PQ: 0 ANSI: 6
[  518.581491] sd 9:0:0:0: Attached scsi generic sg7 type 0

Will repeat without this file in the next Comment.
Comment 4 Freek de Kruijf 2018-01-24 15:08:18 UTC
(In reply to Freek de Kruijf from comment #3)
> Will repeat without this file in the next Comment.

Even with this file in place the device did not show up in the widget for removable devices.
Comment 5 Freek de Kruijf 2018-01-24 15:17:16 UTC
(In reply to Freek de Kruijf from comment #4)
> (In reply to Freek de Kruijf from comment #3)
> > Will repeat without this file in the next Comment.

Without this it now shows up:

[  209.121206] usb 2-2: new SuperSpeed USB device number 2 using xhci_hcd
[  209.144819] usb 2-2: New USB device found, idVendor=4971, idProduct=1015
[  209.144827] usb 2-2: New USB device strings: Mfr=10, Product=11, SerialNumber=3
[  209.144831] usb 2-2: Product: Touro Desk 3.0
[  209.144835] usb 2-2: Manufacturer: HitachiGST
[  209.144839] usb 2-2: SerialNumber: 31001206050000001701
[  209.146660] usb-storage 2-2:1.0: USB Mass Storage device detected
[  209.147535] usb-storage 2-2:1.0: Quirks match for vid 4971 pid 1015: 800000
[  209.147603] scsi host9: usb-storage 2-2:1.0
[  212.173167] scsi 9:0:0:0: Direct-Access     HitachiG ST               0000 PQ: 0 ANSI: 6
[  212.173740] sd 9:0:0:0: Attached scsi generic sg7 type 0
[  212.173854] sd 9:0:0:0: [sdg] 488378623 4096-byte logical blocks: (2.00 TB/1.82 TiB)
[  212.174245] sd 9:0:0:0: [sdg] Write Protect is off
[  212.174251] sd 9:0:0:0: [sdg] Mode Sense: 27 00 00 00
[  212.174616] sd 9:0:0:0: [sdg] No Caching mode page found
[  212.174620] sd 9:0:0:0: [sdg] Assuming drive cache: write through
[  212.191754]  sdg: sdg1
[  212.193242] sd 9:0:0:0: [sdg] Attached SCSI disk
Comment 6 Freek de Kruijf 2018-01-24 15:21:41 UTC
Apparently the problem has been solved by newer software in Tumbleweed.