Bug 1073610 - PackageKit indicates network is available even though it's not
PackageKit indicates network is available even though it's not
Status: RESOLVED DUPLICATE of bug 1103678
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE GNOME
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-20 08:30 UTC by Frank Krüger
Modified: 2019-03-21 20:44 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Plasmashell Output (17.12 KB, text/plain)
2017-12-27 20:16 UTC, Frank Krüger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Krüger 2017-12-20 08:30:23 UTC
Immediately after login the KDE plasma applet for software updates starts even without a working network connection (I am using NetworkManager). This issue does not occur for Leap 42.3.
Comment 1 Fabian Vogt 2017-12-26 15:33:00 UTC
Please restart plasmashell and upload the full output after the applet ran:

"kquitapp5 plasmashell; plasmashell"
Comment 2 Frank Krüger 2017-12-27 20:16:31 UTC
Created attachment 754329 [details]
Plasmashell Output

Here we go.
Comment 3 Fabian Vogt 2017-12-27 20:29:45 UTC
> Is net online: true

Ok, that means PackageKit thinks a network connection is available (for reference: 

Reassigning to PackageKit. For reference, plasma-pk-updates does this:

qCDebug(PLASMA_PK_UPDATES) << "Is net online:" << (PackageKit::Daemon::networkState() > PackageKit::Daemon::Network::NetworkOffline);
Comment 4 Frank Krüger 2017-12-28 09:40:47 UTC
So it seems that the important part of the above output is the following:

plasma-pk-updates: Is net online: false
plasma-pk-updates: Is net mobile: false
plasma-pk-updates: Is net online: false
plasma-pk-updates: Is on battery: true
Plasma Shell startup completed
[...]
networkmanager-qt: void NetworkManager::NetworkManagerPrivate::propertiesChanged(const QVariantMap&) Unhandled property "AllDevices"
networkmanager-qt: void NetworkManager::NetworkManagerPrivate::propertiesChanged(const QVariantMap&) Unhandled property "Capabilities"
networkmanager-qt: void NetworkManager::NetworkManagerPrivate::propertiesChanged(const QVariantMap&) Unhandled property "Devices"
networkmanager-qt: void NetworkManager::NetworkManagerPrivate::propertiesChanged(const QVariantMap&) Unhandled property "GlobalDnsConfiguration"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "LldpNeighbors"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Real"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "LldpNeighbors"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Real"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "LldpNeighbors"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Real"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "LldpNeighbors"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Real"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "LldpNeighbors"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Real"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "LldpNeighbors"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Real"
plasma-pk-updates: Is net mobile: false
plasma-pk-updates: Is net online: true
plasma-pk-updates: Daemon changed
[...]

even though there is no working network connection: 

New Notification:  "Drahtlose Schnittstelle (wlp4s0)" "Es wurde kein Passwort angegeben" -1 & Part of: 0
Comment 5 Frank Krüger 2018-03-04 08:14:15 UTC
I am also experiencing this issue with current Leap 15.0 Beta.
Comment 6 Frank Krüger 2018-06-12 21:26:51 UTC
No activity/solution to be expected.
Comment 7 Fabian Vogt 2018-06-13 06:53:33 UTC
"RESOLVED NORESPONSE" means that the reporter did not come back with information. As this is not the case here, I'll reopen it.
Comment 8 Frank Krüger 2018-07-22 13:30:19 UTC
Is there any news or progress to be expected? The issue was originally reported on Dec 2017.
Comment 9 Frank Krüger 2019-03-21 20:44:19 UTC
The issue seems to be a dup of bug#1103678.

*** This bug has been marked as a duplicate of bug 1103678 ***