Bug 1073215 - Please fix that IBus mess.
Please fix that IBus mess.
Status: RESOLVED INVALID
: 1074168 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Usability
Current
x86-64 Linux
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-17 21:49 UTC by Daniel Ziltener
Modified: 2018-01-09 13:16 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ziltener 2017-12-17 21:49:00 UTC
I didn't get any kind of answer except of mild confusion in the forums and on IRC. Is IBus mandatory now? People suggested it got installed as a dependency, but last week I made a fresh Tumbleweed/KDE install and had IBus on first boot. With the completely wrong keyboard layout nonetheless.

I can't even have deadkeys with IBus. I need to uninstall and block it to get rid of it. There seems to be no advantage to having it. Plus why have a third place to mess up keyboard layouts, after YaST2 and KDE System Settings?

Now tell a newbie user how to handle this mess.
Comment 1 Andreas Stieger 2017-12-18 17:04:28 UTC
I think you should go back to community support with this bug written as is.
Comment 2 Daniel Ziltener 2017-12-19 09:00:30 UTC
With answers like this, it's no wonder this distribution is going down the shitters...
Comment 3 Andreas Stieger 2017-12-19 09:14:06 UTC
Yes, it would seem that not everyone gets to do it the way they want.
Comment 4 Wolfgang Bauer 2017-12-20 21:17:12 UTC
FYI, ibus is pulled in now because libreoffice-kde4 was dropped. It couldn't be built anymore due to the switch to OpenSSL 1.1.0, libqt4 and kdelibs4 don't support 1.1.0 and require 1.0.x which led to conflicts.

Therefore libreoffice-gnome is now installed for KDE/Plasma5 as well. (and ibus supplements libreoffice-gnome for some reason)

Will be fixed with LibreOffice 6.0, libreoffice-kde4 will be back as we patched both libqt4 and kdelibs4 meanwhile to support OpenSSL 1.1.0.
Comment 5 Stefan Dirsch 2018-01-09 13:16:07 UTC
*** Bug 1074168 has been marked as a duplicate of this bug. ***