Bug 1073174 - version 10.2.0 of open-vm-tools is available
version 10.2.0 of open-vm-tools is available
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Tools
Current
VMWare openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Mike Latimer
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-15 22:08 UTC by Oliver Kurth
Modified: 2018-04-30 16:52 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurth 2017-12-15 22:08:22 UTC
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.84 Safari/537.36
Build Identifier: 

We have released open-vm-tools 10.2.0.

open-vm-tools 10.2.0 is available for download from GitHub:

https://github.com/vmware/open-vm-tools/releases/tag/stable-10.2.0

For more details and changes, please refer to the release notes at 

https://github.com/vmware/open-vm-tools/blob/stable-10.2.x/ReleaseNotes.md

or the ChangeLog at:

https://github.com/vmware/open-vm-tools/blob/stable-10.2.x/open-vm-tools/ChangeLog

Reproducible: Always
Comment 1 Mike Latimer 2017-12-15 23:54:21 UTC
Thanks, Oliver.

I'd like to ensure the udev rules problem I mentioned upstream is fixed properly in this build. If you need anything to look into it further on your side, please let me know. Otherwise, I'll get this added to TW soon.
Comment 2 Oliver Kurth 2017-12-16 02:44:22 UTC
Unfortunately the issue is not fixed in this release, it came up too late.

I was able to reproduce it, and we are likely going to use the fix you sent as a pull request https://github.com/vmware/open-vm-tools/pull/216. I will try to merge this into the stable-10.2.x soon.
Comment 3 Swamp Workflow Management 2018-02-09 17:10:08 UTC
SUSE-RU-2018:0410-1: An update that has three recommended fixes can now be installed.

Category: recommended (low)
Bug References: 1062837,1063320,1073174
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP2 (src):    open-vm-tools-10.2.0-9.6.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    open-vm-tools-10.2.0-9.6.1
Comment 4 Swamp Workflow Management 2018-02-09 17:10:56 UTC
SUSE-RU-2018:0411-1: An update that has three recommended fixes can now be installed.

Category: recommended (low)
Bug References: 1062837,1063320,1073174
CVE References: 
Sources used:
SUSE Linux Enterprise Server 11-SP4 (src):    open-vm-tools-10.2.0-8.6.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    open-vm-tools-10.2.0-8.6.1
Comment 5 Swamp Workflow Management 2018-02-09 17:11:41 UTC
SUSE-RU-2018:0412-1: An update that has three recommended fixes can now be installed.

Category: recommended (low)
Bug References: 1062837,1063320,1073174
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP3 (src):    open-vm-tools-10.2.0-3.6.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    open-vm-tools-10.2.0-3.6.1
SUSE CaaS Platform ALL (src):    open-vm-tools-10.2.0-3.6.1
Comment 6 Swamp Workflow Management 2018-02-14 17:09:16 UTC
openSUSE-RU-2018:0440-1: An update that has three recommended fixes can now be installed.

Category: recommended (low)
Bug References: 1062837,1063320,1073174
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    open-vm-tools-10.2.0-7.1
Comment 7 Mike Latimer 2018-04-30 16:52:33 UTC
Cleaning up old bugs. This has already been fixed and released.