Bug 1072734 - claws mail failed STARTTLS with libetpan
claws mail failed STARTTLS with libetpan
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 openSUSE Factory
: P5 - None : Minor (vote)
: ---
Assigned To: Marcus Rückert
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-13 19:00 UTC by Oliver Bengs
Modified: 2017-12-28 22:38 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Bengs 2017-12-13 19:00:26 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build Identifier: 

claws-mail-3.15.1 can't connect to IMAP_Server with STARTTLS with libetpan17-1.6

Reproducible: Always

Steps to Reproduce:
1. Install claws-mail from standard repo
2. Install libetpan from standard repo
3. Try connect claws-mail with STARTTLS enabled IMAP
Actual Results:  
imap starttls run - can't tls_open

Expected Results:  
Connection should be etablished

Install libetpan17 from server:mail repo is solving this problem
Comment 1 t neo 2017-12-14 13:04:49 UTC
I had the same issue. Thanks for this report including the fix. Awkward that Tumbleweed reports to have the same libetpan17 version, yet it is not working.
Comment 2 Marcus Rückert 2017-12-15 11:01:33 UTC
created request id 557303 will fix it.

and even though it is the same library version doesnt mean that it has the same binary content. in this case the openssl detection broke and it just didnt link SSL support anymore. the patch fixed this.
Comment 3 John Andrew McInnes 2017-12-28 22:38:19 UTC
I started getting "*** SSL/TLS handshake failed" errors recently. I'm assuming its the same bug.