Bug 1072651 - [Build 20171212] FTBFS: vim fails to build in openSUSE:Factory:PowerPC - ppc64
[Build 20171212] FTBFS: vim fails to build in openSUSE:Factory:PowerPC - ppc64
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
PowerPC Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ismail Dönmez
E-mail List
http://openqa.opensuse.org/tests/5586...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-13 13:23 UTC by Michel Normand
Modified: 2018-02-01 16:30 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2017-12-13 13:23:37 UTC
the missing vim-data is probably related to the vim build failure
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:PowerPC/vim/standard/ppc64

## Observation

openQA test in scenario opensuse-Tumbleweed-NET-ppc64-minimalx@ppc64 fails in
[vim](http://openqa.opensuse.org/tests/558616/modules/vim/steps/5)


## Reproducible

Fails since (at least) Build [20171212](http://openqa.opensuse.org/tests/558616) (current job)


## Expected result

Last good: [20171212](http://openqa.opensuse.org/tests/558356) (or more recent)


## Further details

Always latest result in this scenario: [latest](http://openqa.opensuse.org/tests/latest?distri=opensuse&flavor=NET&machine=ppc64&version=Tumbleweed&arch=ppc64&test=minimalx)
Comment 1 Dominique Leuenberger 2017-12-13 16:12:52 UTC
Actually there was 'just' an invalid test change:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4050/files

A fix is in the makes already (vim-data is not mandatory, and is never present on minimalX installs; the test meant to ensure it is not there on JeOS)

(the build failure is still something to look at of course)
Comment 2 Dominique Leuenberger 2017-12-13 16:41:17 UTC
on 2nd thought, let's keep this ticket and just track the build failure.

Here the explanation why the failure causes this issue:

* vim has a Recommends: vim-data = %{version}-%{release}
* vim-data is a noarch package, meaning only one of a random arch being built is shipped (at this time it was ppc64le)
* since vim/ppc64 fails to build, it is still at vim 7.x, but the provided vim-data is already 8.0, and the recommends does consequently not match, resulting in the installer silently skipping it (which it is allowed to do: it's recommended only, not required)
Comment 3 Dominique Leuenberger 2017-12-13 17:17:42 UTC
The failure was in the test suite - namely 'test87'

a rebuild of vim was successful (random test suite failure)
Comment 4 Dominique Leuenberger 2018-02-01 16:30:56 UTC
(In reply to Dominique Leuenberger from comment #3)
> The failure was in the test suite - namely 'test87'
> 
> a rebuild of vim was successful (random test suite failure)