Bug 1072581 - virt-manager fails to open VM window a second time: 'NoneType' object has no attribute 'change_run_text'
virt-manager fails to open VM window a second time: 'NoneType' object has no ...
Status: RESOLVED DUPLICATE of bug 1071825
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KVM
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-13 09:23 UTC by Robert Munteanu
Modified: 2017-12-13 15:32 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
console.log (19.74 KB, text/plain)
2017-12-13 09:23 UTC, Robert Munteanu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Munteanu 2017-12-13 09:23:44 UTC
Created attachment 752773 [details]
console.log

I'm using virt-manager to interact with a couple of libvirtd managed machines. This used to work fine when I was using only one machine, but as I added another machine I got seemingly spurious errors.

I nailed it down to opening the VM window a second time. First time it works OK, second time it fails with

summary=Error launching details: 'NoneType' object has no attribute 'change_run_text'
details=Error launching details: 'NoneType' object has no attribute 'change_run_text'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 837, in _show_vm_helper
    details.show()
  File "/usr/share/virt-manager/virtManager/details.py", line 653, in show
    self.refresh_vm_state()
  File "/usr/share/virt-manager/virtManager/details.py", line 1316, in refresh_vm_state
    self.change_run_text(vm.has_managed_save())
  File "/usr/share/virt-manager/virtManager/details.py", line 1299, in change_run_text
    self.widget("details-vm-menu").get_submenu().change_run_text(text)
AttributeError: 'NoneType' object has no attribute 'change_run_text'

The only workaround is to kill virt-manager and start it up again. It only works once per virtual machine, the second time it always fails with the same error.
Comment 1 Robert Munteanu 2017-12-13 09:35:38 UTC
A slightly simpler within virt-manager is to disconnect/connect from the 'QEMU/KVM' connection
Comment 2 Charles Arnold 2017-12-13 15:29:24 UTC
A fix for this is available in the Factory virt-manager. Hopefully the next
Tumbleweed build will have it.

*** This bug has been marked as a duplicate of bug 1071825 ***
Comment 3 Robert Munteanu 2017-12-13 15:32:42 UTC
That was fast! Thanks for the rapid response.