Bug 1072521 - texlive-filesystem incorrectly requires 'python' instead of '/usr/bin/python' or python = 2
texlive-filesystem incorrectly requires 'python' instead of '/usr/bin/python'...
Status: RESOLVED DUPLICATE of bug 1077170
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dr. Werner Fink
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-13 04:03 UTC by Christoph Feck
Modified: 2018-01-26 17:33 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2017-12-13 04:03:00 UTC
When switching from python2 to python3, the yast installer complained about missing "/usr/bin/python" command when running the texlive-filesystem post-install script. Softlinking the missing command to "/usr/bin/python3" confirms that the script indeed requires the old python2 interpreter.

So the requires-field needs to be adjusted.
Comment 1 Dr. Werner Fink 2018-01-26 17:33:30 UTC
Gone with fix for boo#1077170

*** This bug has been marked as a duplicate of bug 1077170 ***