Bug 1072418 - Skrooge requires libQT5Cor.so.5(QT5.9.2_...) after release Tumbleweed snapshot 20171210 with QT5.9.3
Skrooge requires libQT5Cor.so.5(QT5.9.2_...) after release Tumbleweed snapsho...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-12 15:31 UTC by Max vdP
Modified: 2017-12-12 19:16 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max vdP 2017-12-12 15:31:07 UTC
I installed Tumbleweed snapshot 20171210. Skrooge got removed (with my permission). I didn't understood why exactly and tried to install Skrooge again with Yast2 (from obs://buuild.opensuse.org/KDE:Extra). I got the message "Nothing provides libQT5Core.so.5(QT5.9.2_PRIVATE_API)(64bit) needed by skrooge-2.10.5-1.4.x86_64". 
In the mailing list of the new Tumbleweed snapshot 20171210 release I found that one of the updates is libqt5-qtbase (5.9.2 -> 5.9.3). So explained but not resolved. 

Version 2.10.5-1.4 of Skrooge requires old libs:
libQt5Core.so.5(Qt_5.9.2_PRIVATE_API)(64bit)
libQt5Sql.so.5(Qt_5.9.2_PRIVATE_API)(64bit)

Can Skrooge update to QT 5.9.3? If that is the problem.
Comment 1 Wolfgang Bauer 2017-12-12 16:14:15 UTC
(In reply to Max vdP from comment #0)
> Can Skrooge update to QT 5.9.3?

No, sorry.

I just triggered a rebuild manually, but it still builds against Qt 5.9.2.

You need to wait until OBS notices that 5.9.3 is in Tumbleweed now... (then it should actually resolve itself I think)
Comment 2 Christophe Giboudeaux 2017-12-12 16:50:48 UTC
I've just reenabled publishing for KDE:Extra/openSUSE_Tumbleweed. The updated package should be available shortly.
Comment 3 Max vdP 2017-12-12 16:54:31 UTC
Jeehee. That is fast! Thanks in advance.
Comment 4 Wolfgang Bauer 2017-12-12 16:57:44 UTC
Unfortunately in won't help though, as it is still built against and requires Qt 5.9.2. (as I wrote)
Comment 5 Max vdP 2017-12-12 16:59:13 UTC
Ahhh. Okee, i'll wait.
Comment 6 Wolfgang Bauer 2017-12-12 18:37:45 UTC
The package was rebuilt with Qt 5.9.3 meanwhile, so the dependency problem should be gone.
Comment 7 Max vdP 2017-12-12 19:16:23 UTC
Yes! Installed again. Skrooge works. Thanks!