Bugzilla – Bug 1072418
Skrooge requires libQT5Cor.so.5(QT5.9.2_...) after release Tumbleweed snapshot 20171210 with QT5.9.3
Last modified: 2017-12-12 19:16:23 UTC
I installed Tumbleweed snapshot 20171210. Skrooge got removed (with my permission). I didn't understood why exactly and tried to install Skrooge again with Yast2 (from obs://buuild.opensuse.org/KDE:Extra). I got the message "Nothing provides libQT5Core.so.5(QT5.9.2_PRIVATE_API)(64bit) needed by skrooge-2.10.5-1.4.x86_64".
In the mailing list of the new Tumbleweed snapshot 20171210 release I found that one of the updates is libqt5-qtbase (5.9.2 -> 5.9.3). So explained but not resolved.
Version 2.10.5-1.4 of Skrooge requires old libs:
Can Skrooge update to QT 5.9.3? If that is the problem.
(In reply to Max vdP from comment #0)
> Can Skrooge update to QT 5.9.3?
I just triggered a rebuild manually, but it still builds against Qt 5.9.2.
You need to wait until OBS notices that 5.9.3 is in Tumbleweed now... (then it should actually resolve itself I think)
I've just reenabled publishing for KDE:Extra/openSUSE_Tumbleweed. The updated package should be available shortly.
Jeehee. That is fast! Thanks in advance.
Unfortunately in won't help though, as it is still built against and requires Qt 5.9.2. (as I wrote)
Ahhh. Okee, i'll wait.
The package was rebuilt with Qt 5.9.3 meanwhile, so the dependency problem should be gone.
Yes! Installed again. Skrooge works. Thanks!