Bug 1072274 - network/tor: replace torctl with systemd service file
network/tor: replace torctl with systemd service file
Status: RESOLVED FIXED
: 1159844 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
Other Other
: P5 - None : Normal (vote)
: Current
Assigned To: Bernhard Wiedemann
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-11 23:27 UTC by nusenu nusenu
Modified: 2020-01-13 09:59 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
/usr/lib/systemd/system/tor-master.service (from Fedora) (395 bytes, text/plain)
2017-12-11 23:27 UTC, nusenu nusenu
Details
/usr/lib/systemd/system/tor.service (from Fedora) (988 bytes, text/plain)
2017-12-11 23:29 UTC, nusenu nusenu
Details
/usr/share/tor/defaults-torrc (54 bytes, text/plain)
2017-12-11 23:31 UTC, nusenu nusenu
Details
/etc/logrotate.d/tor (based on Fedora's) (254 bytes, text/plain)
2017-12-11 23:33 UTC, nusenu nusenu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nusenu nusenu 2017-12-11 23:27:35 UTC
Created attachment 752465 [details]
/usr/lib/systemd/system/tor-master.service (from Fedora)

The current tor.service systemd file is a wrapper around torctl instead of being a native service file.

This ticket is about making tor.service a native systemd service file.

I'm attaching the following files:

/usr/lib/systemd/system/tor.service
/usr/lib/systemd/system/tor-master.service
/usr/share/tor/defaults-torrc
/etc/logrotate.d/tor

These files are mostly copies from the Fedora package with very minor changes to the specifics in openSUSE (i.e. tor username).

I tested them briefly on openSUSE Leap 42.3.

This is related to #1071981
Comment 1 nusenu nusenu 2017-12-11 23:29:16 UTC
Created attachment 752466 [details]
/usr/lib/systemd/system/tor.service (from Fedora)
Comment 2 nusenu nusenu 2017-12-11 23:31:36 UTC
Created attachment 752468 [details]
/usr/share/tor/defaults-torrc
Comment 3 nusenu nusenu 2017-12-11 23:33:06 UTC
Created attachment 752472 [details]
/etc/logrotate.d/tor (based on Fedora's)
Comment 4 nusenu nusenu 2017-12-11 23:36:43 UTC
The Log entry in defaults-torrc should probably be replaced with the current default (notice to /var/log/tor/tor.log).
Comment 5 Bernhard Wiedemann 2020-01-07 11:46:28 UTC
*** Bug 1159844 has been marked as a duplicate of this bug. ***
Comment 6 Alex B. 2020-01-07 13:09:33 UTC
Current devel-version works for me.
Comment 7 Swamp Workflow Management 2020-01-08 20:50:05 UTC
This is an autogenerated message for OBS integration:
This bug (1072274) was mentioned in
https://build.opensuse.org/request/show/761967 Factory / tor
Comment 8 Bernhard Wiedemann 2020-01-13 09:59:39 UTC
Let's count this as done.

The only thing missing is that the logrotate only reloads tor.service instead of tor-master.service

but that can come later, if someone adds a tor@.service