Bug 1072249 - [Build 20171210] openQA test fails in first_boot
[Build 20171210] openQA test fails in first_boot
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Kubic Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-11 21:08 UTC by Dominique Leuenberger
Modified: 2017-12-13 10:52 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2017-12-11 21:08:10 UTC
openQA reported a failure (across all Kubic tests) in first_boot test, e.g.
https://openqa.opensuse.org/tests/556575#step/first_boot/8

The system does not reach a login prompt

According serial.txt of that test run, the serial console DID reach the login prompt though; the wait time to boot is 5 minutes
Comment 1 Dominique Leuenberger 2017-12-12 09:40:59 UTC
Reproduced locally - frm my first findings, the issue is simply 'getty@.service' not being enabled by default (vendor preset disabled)

This is 'normally' part of 90-default-SUSE.preset, but this is not part of the CAASP branding package; none of the other presets shipped in systemd-presets-branding-CAASP (70-default-CAASP, 90-default-openSUSe, 90-default-disable, 99-default) enable (or mention) getty@.service

After issuing 'systemctl enable getty@; reboot', the login also work son tty1, as expected
Comment 2 Thorsten Kukuk 2017-12-12 10:46:22 UTC
(In reply to Dominique Leuenberger from comment #1)

> This is 'normally' part of 90-default-SUSE.preset, but this is not part of
> the CAASP branding package; none of the other presets shipped in
> systemd-presets-branding-CAASP (70-default-CAASP, 90-default-openSUSe,
> 90-default-disable, 99-default) enable (or mention) getty@.service

Ok, the problem is this change:

-------------------------------------------------------------------
Fri Nov  3 09:12:26 UTC 2017 - olaf@aepfle.de

- Move common entries into default-SUSE.preset (bsc#1060676)


And systemd-presets-branding-CAASP was not adjusted, only 
systemd-presets-branding-SLE ...
Comment 3 Richard Brown 2017-12-13 10:52:06 UTC
Resolved in 20171212