Bug 1072055 - Rust package does not pull all required dependencies
Rust package does not pull all required dependencies
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Luke Jones
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-10 16:41 UTC by Maciek Krawiec
Modified: 2018-01-01 01:05 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciek Krawiec 2017-12-10 16:41:18 UTC
I run the system with global zypp no-recommends set to true and when I install the package rust the command rustc cannot compile a simple hello world because rust-std and gcc are not installed

Running

>> rustc hello.rs

Without rust-std results in

>> error[E0463]: can't find crate for `std`

Without of gcc results in

>> error: could not exec the linker `cc`: No such file or directory (os error 2)

So it turns out that both packages are required in order for basic rustc functions
Comment 1 Luke Jones 2018-01-01 01:05:26 UTC
This is correct behaviour - if someone is developing on a limited architecture such as ARM and is writing only small/basic programs/embedded they will not need the rust-std libs.

The libs contain such things as the String and Vec data types and macros such as println!. 

Neither of these (and more) are required functionality for writing a rust program, especially not for embedded applications where space use is critical.

Closing as not a bug.