Bug 1071825 - AttributeError: 'NoneType' object has no attribute 'change_run_text'
AttributeError: 'NoneType' object has no attribute 'change_run_text'
Status: RESOLVED FIXED
: 1072581 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Tools
Current
Other Other
: P3 - Medium : Major (vote)
: ---
Assigned To: Charles Arnold
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-07 21:05 UTC by Martin Wilck
Modified: 2018-01-02 20:10 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
virt-manager log file (33.59 KB, text/plain)
2017-12-07 21:05 UTC, Martin Wilck
Details
Fix for the bug (603 bytes, patch)
2017-12-11 22:19 UTC, Charles Arnold
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wilck 2017-12-07 21:05:31 UTC
Created attachment 751986 [details]
virt-manager log file

The above error occurs when I try to open the details view for a VM through the virt-manager overview UI for the second time (i.e. open details view, close it again, and open again). It doesn't seem to matter whether or not the VM is stopped in the meantime.

The attached log file shows several occurences of this problem.
Comment 1 Charles Arnold 2017-12-08 18:26:13 UTC
(In reply to Martin Wilck from comment #0)
> Created attachment 751986 [details]
> virt-manager log file
> 
> The above error occurs when I try to open the details view for a VM through
> the virt-manager overview UI for the second time (i.e. open details view,
> close it again, and open again). It doesn't seem to matter whether or not
> the VM is stopped in the meantime.
> 
> The attached log file shows several occurences of this problem.

An update on this bug.
I've narrowed this problem down to the close event not being picked
up properly. When closing the details window from the top right corner by
clicking the [x], no close event is caught and this leaves things in a bad
state when reopening. If you close from the pull down menu on the details
dialog 'File' -> 'Close', it reopens up okay.
Comment 2 Charles Arnold 2017-12-11 22:19:18 UTC
Created attachment 752458 [details]
Fix for the bug
Comment 3 Bernhard Wiedemann 2017-12-11 22:40:05 UTC
This is an autogenerated message for OBS integration:
This bug (1071825) was mentioned in
https://build.opensuse.org/request/show/556304 Factory / virt-manager
Comment 5 Charles Arnold 2017-12-13 15:29:24 UTC
*** Bug 1072581 has been marked as a duplicate of this bug. ***
Comment 6 Charles Arnold 2018-01-02 20:10:58 UTC
This is fixed in Tumbleweed build 20171216 or newer.