Bug 1071688 - tumbleweed is missing lsb5 package
tumbleweed is missing lsb5 package
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-07 09:23 UTC by Marvin FourtyTwo
Modified: 2017-12-07 13:57 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marvin FourtyTwo 2017-12-07 09:23:25 UTC
yes, lsb is ancient (even V5), but some proprietary apps want it. Lsb5 package was provided with Leap 42.3 and it seems that it was dropped for some reason. Would it possible to provide it again?

Another reason is that tumbleweed provides lsb V4 which is even older and pulls in qt3 which in turn pulls in the base of kde4 and kde3 styles.
Comment 1 Martin Pluskal 2017-12-07 13:21:21 UTC
(In reply to Marvin FourtyTwo from comment #0)
> yes, lsb is ancient (even V5), but some proprietary apps want it. Lsb5
> package was provided with Leap 42.3 and it seems that it was dropped for
> some reason.
Why would you assume that reason does not exist anymore? If I recall correctly it is not possible to fulfill dependencies of lsb5 on Factory.
Comment 2 Marvin FourtyTwo 2017-12-07 13:54:29 UTC
I hadn't found the factory package, but Leap package gave:

error: Failed dependencies:
        libpng15.so.15()(64bit) is needed by lsb5-desktop-5.0-4.2.x86_64
        perl(B::Lint) is needed by lsb5-languages-5.0-4.2.x86_64
        perl(CGI::Apache) is needed by lsb5-languages-5.0-4.2.x86_64
        perl(File::CheckTree) is needed by lsb5-languages-5.0-4.2.x86_64
        perl(Pod::LaTeX) is needed by lsb5-languages-5.0-4.2.x86_64
Comment 3 Marvin FourtyTwo 2017-12-07 13:57:32 UTC
(In reply to Marvin FourtyTwo from comment #2)
> I hadn't found the factory package, but Leap package gave:
> 
> error: Failed dependencies:
>         libpng15.so.15()(64bit) is needed by lsb5-desktop-5.0-4.2.x86_64
>         perl(B::Lint) is needed by lsb5-languages-5.0-4.2.x86_64
>         perl(CGI::Apache) is needed by lsb5-languages-5.0-4.2.x86_64
>         perl(File::CheckTree) is needed by lsb5-languages-5.0-4.2.x86_64
>         perl(Pod::LaTeX) is needed by lsb5-languages-5.0-4.2.x86_64

sorry, I misread your comment. It sounds just strange to me that lsb4 is no problem while lsb5 is. Ok, maybe more (obsolete) packages includes.