Bug 1071626 - python2-warlock 1.3.0 incompatible with python-glanceclient 2.8.0
python2-warlock 1.3.0 incompatible with python-glanceclient 2.8.0
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Other Other
: P2 - High : Major (vote)
: ---
Assigned To: Thomas Bechtold
E-mail List
Depends on:
  Show dependency treegraph
Reported: 2017-12-06 22:07 UTC by Blaine Gardner
Modified: 2018-03-19 10:26 UTC (History)
2 users (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Blaine Gardner 2017-12-06 22:07:44 UTC
There is an issue with the python-glanceclient 2.8.0 dependencies. python-warlock > 1.0.1 is in the specfile, but after I updated to python-warlock 1.3.0, I see when trying to use the 'openstack' CLI, the dependency should be python-warlock >1.0.1, <2, and !=1.3.0. The dependency should be updated.

Additionally, python-warlock should be updated to something other than 1.3.0, whether that is a revert or moving forward to a newer version.

$ openstack --debug --help
Could not load EntryPoint.parse('access_token_create = openstackclient.identity.v3.token:CreateAccessToken')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 35, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2404, in load
    self.require(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2427, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 875, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (warlock 1.3.0 (/usr/lib/python2.7/site-packages), Requirement.parse('warlock!=1.3.0,<2,>=1.0.1'), set(['python-glanceclient']))
Comment 1 Blaine Gardner 2017-12-06 22:12:37 UTC
Both packages in question come from openSUSE:Factory and are maintained by Dominique Leuenberger (dimstar_suse)
Comment 2 Blaine Gardner 2017-12-06 22:20:30 UTC
Clarification: python2-warlock is the package on my system I've found to be incompatible, and python3-warlock is also at the same version (1.3.0-1)
Comment 3 Dominique Leuenberger 2017-12-07 08:24:51 UTC
(In reply to Blaine Gardner from comment #1)
> Both packages in question come from openSUSE:Factory and are maintained by
> Dominique Leuenberger (dimstar_suse)

That is definitively not true - I'm 'just' the release manager of Tumbleweed and check in ALL 12k packages to the distro. But I am luckily not the one to maintain all 12k packages

> osc maintainer python3-warlock
Defined in project:  devel:languages:python
  bugowner of python3-warlock : 


> osc maintainer python-glanceclient
Defined in project:  Cloud:OpenStack:Kilo
  bugowner of python-glanceclient : 

  maintainer of python-glanceclient : 
Comment 6 Thomas Bechtold 2018-01-23 07:22:21 UTC
@Blaine, we need a) to wait for a new python-glanceclient release from upstream or b) downgrade python-warlock in openSUSE:Factory. I would prefer a).
But you can also use the python-openstackclient "openstack image ..." to do most of the things, I guess.
Comment 7 Blaine Gardner 2018-01-23 08:48:49 UTC
I'm quite happy to wait for a new python-glanceclient release from upstream.

I used snapper to roll back the warlock install to the previous version, so I'm still working currently. Thanks, Thomas.
Comment 8 Thomas Bechtold 2018-03-19 10:26:43 UTC
There is now python-glanceclient 2.9.1 in openSUSE:Factory. This should work. Please reopen if you still see this problem.