Bug 1071404 - bootstrap.py could not work
bootstrap.py could not work
Status: RESOLVED DUPLICATE of bug 1070344
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: High Availability
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: SUSE Linux Enterprise High Availability Team
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-06 02:57 UTC by Larry Chen
Modified: 2017-12-06 09:57 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Chen 2017-12-06 02:57:50 UTC
bootstrap.py can not work on lastest tumbleweed

###############################################

File "/usr/lib/python3.6/site-packages/crmsh/bootstrap.py", line 1043, in check_amazon
    if not is_program("dmidecode"): 

###############################################
here should be utils.is_program("dmidecode")

I found in ClusterLabs repo this problem has already been fixed on master branch.
But tumbleweed has not merged it.

:-)
Comment 1 Kristoffer Gronlund 2017-12-06 09:57:29 UTC
The fix is submitted now. It takes a while for submissions to get through the staging process and into Tumbleweed.

Thanks!

*** This bug has been marked as a duplicate of bug 1070344 ***