Bug 1071116 - package openssl version 1.1.0g is incompatible with package openssl-1_0_0
package openssl version 1.1.0g is incompatible with package openssl-1_0_0
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
PC openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Vítězslav Čížek
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-04 17:06 UTC by Giacomo Comes
Modified: 2017-12-13 09:23 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giacomo Comes 2017-12-04 17:06:19 UTC
After the upgrade of openssl from 1.0.2m to 1.1.0g if I do a zypper up I get:

The following 8 packages are going to be REMOVED:
  libQtWebKit-devel libavahi-qt4-devel libopenssl-1_0_0-devel libqimageblitz-devel libqt4-devel openssl-1_0_0 phonon-devel projectM-devel

It looks like openssl is incompatible with openssl-1_0_0 and therefore in order to upgrade openssl I need to remove the packages: libQtWebKit-devel libavahi-qt4-devel  libqimageblitz-devel libqt4-devel phonon-devel projectM-devel
which depends on libopenssl-1_0_0-devel.
Comment 1 Tomáš Chvátal 2017-12-13 09:23:25 UTC
This is proper resolution, the qt4 libraries are based on openssl-1.0 only and the devel files are conflicting so you can keep either openssl-1_0_0-devel or openssl-1_1_0-devel, while some of your packages are requiring the new one and some the old one.

Simply put the Qt4 is obsolete but there are attempts to port it to new api by the kde team.