Bug 1071090 - incomplete change with service files and sysconfig file
incomplete change with service files and sysconfig file
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Samba
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: The 'Opening Windows to a Wider World' guys
The 'Opening Windows to a Wider World' guys
:
Depends on: 1065551
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-04 15:50 UTC by Marcus Rückert
Modified: 2018-08-29 15:52 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Rückert 2017-12-04 15:50:19 UTC
just adding the -F to the default sysconfig file wont help to update existing sysconfig files.

you could use sysconf_addword for it but tbh those options could also be directly in the service file and the sysconfig file would document that these options are *always* set.

furthermore an upstream dev recommended to just use the upstream service files from https://git.samba.org/?p=samba.git;a=commitdiff;h=8b6f58194da7e849cdb9d20712dff49b17a93a77

as the process group cmdline option is also important.
Comment 1 Aurelien Aptel 2018-03-02 17:19:27 UTC
I'm not sure I understand what needs to be done here.

If TW and SLE15 get the original upstream systemd files with the process-group settings and whatnot would that be enough?

IIUC sysconf_addword is a tool to modify sysconf files. Where should we call it in case of an update? Is this done in the spec file?

Thanks for any explanations.
Comment 2 Marcus Rückert 2018-03-05 12:34:58 UTC
you would need to fix the existing sysconfig files.

in a %post scriptlet you could fix it.
Comment 3 Aurelien Aptel 2018-04-12 08:35:22 UTC
I've added a %post scriptlet to forcefully update samba sysconfig (remove the flags) if they are already in the unit file. This fixes upgrading on Tumbleweed.

https://build.opensuse.org/request/show/595751
Comment 8 Swamp Workflow Management 2018-08-03 19:10:46 UTC
SUSE-RU-2018:2182-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1065551,1071090,1088574,1093864,1094881,1099702
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Basesystem 15 (src):    samba-4.7.8+git.62.c1052da2b4e-4.7.4, talloc-2.1.11-3.3.4, talloc-man-2.1.11-3.3.3, tevent-0.9.36-4.3.3, tevent-man-0.9.36-4.3.3
SUSE Linux Enterprise High Availability 15 (src):    samba-4.7.8+git.62.c1052da2b4e-4.7.4
Comment 9 Swamp Workflow Management 2018-08-08 22:26:36 UTC
openSUSE-RU-2018:2260-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1065551,1071090,1088574,1093864,1094881,1099702
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    samba-4.7.8+git.62.c1052da2b4e-lp150.3.3.1, talloc-2.1.11-lp150.2.3.1, talloc-man-2.1.11-lp150.2.3.1, tevent-0.9.36-lp150.2.3.1, tevent-man-0.9.36-lp150.2.3.1
Comment 10 James McDonough 2018-08-29 15:52:02 UTC
maintenance shipped, closing