Bug 1070985 - vagrant depends on old rubygem-childprocess
vagrant depends on old rubygem-childprocess
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Other
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Robert Munteanu
E-mail List
Depends on:
  Show dependency treegraph
Reported: 2017-12-04 09:31 UTC by Markos Chandras
Modified: 2018-07-17 13:41 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras 2017-12-04 09:31:15 UTC
In the vagrant spec file I see the following constrain

BuildRequires:  %{rubygem childprocess <= 0.7 }

However, when I try to install the vagrant-disksize plugin I get the following error

$ vagrant plugin install vagrant-disksize
Installing the 'vagrant-disksize' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies childprocess (= 0.6.3) and childprocess (= 0.8.0)
  Activated childprocess-0.8.0
  which does not match conflicting dependency (= 0.6.3)

  Conflicting dependency chains:
    childprocess (= 0.8.0), 0.8.0 activated

    childprocess (= 0.6.3)

  Gems matching childprocess (= 0.6.3):

I presume that if the plugin claims to work with childprocess-0.8.0 then it expects vagrant to work with this version as well.

I was wondering if BuildRequires:  %{rubygem childprocess <= 0.7 } is actually true or our vagrant package is quite old (1.9.8 is out, 2.X too)
Comment 1 Markos Chandras 2017-12-04 09:41:37 UTC
Actually, removing ruby2.4-rubygem-childprocess and only keeping ruby2.4-rubygem-childprocess-0_6 allowed the plugin to use the correct childprocess and be installed successfully. Maybe that 'fix' is the correct thing to do but I am leaving this bug open just in case there is a real bug here.
Comment 2 Robert Munteanu 2018-07-17 13:22:32 UTC
vagrant 2.1.1 is now in TW, can you please retry? Although, to my knowledge, plugin installation still does not work.

FWIW the dependencies have changed:

$ rpm -q --requires vagrant | grep child
rubygem(ruby:2.5.0:childprocess:0.6) >= 0.6
Comment 3 Markos Chandras 2018-07-17 13:26:28 UTC
Yeah it works fine for me right now in TW
Comment 4 Robert Munteanu 2018-07-17 13:33:51 UTC
(In reply to Markos Chandras from comment #3)
> Yeah it works fine for me right now in TW

Can we then resolve this as fixed?
Comment 5 Markos Chandras 2018-07-17 13:41:35 UTC
(In reply to Robert Munteanu from comment #4)
> (In reply to Markos Chandras from comment #3)
> > Yeah it works fine for me right now in TW
> Can we then resolve this as fixed?

Yep lets do it