Bug 1070851 - 502 Bad Gateway in update OS
502 Bad Gateway in update OS
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: libzypp
Current
x86-64 Other
: P3 - Medium : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-01 20:28 UTC by mehdi a.
Modified: 2018-10-18 17:14 UTC (History)
4 users (show)

See Also:
Found By: Other
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mehdi a. 2017-12-01 20:28:59 UTC
i get error when i want to update by using command "sudo zypper dup" :


Download (curl) error for 'http://download.opensuse.org/repositories/M17N/openSUSE_Tumbleweed/repodata/repomd.xml':
Error code: HTTP response: 502
Error message: The requested URL returned error: 502 Bad Gateway
Comment 1 Oliver Kurz 2018-07-29 12:57:53 UTC
Even our SLE openQA tests can now reproduce this issue, e.g. see https://openqa.suse.de/tests/1856659#step/zypper_patch/6 , sorry internal link.

To my understanding problems like these can always sporadically appear when any remote transaction is involved, e.g. network. Hitting this in interactive mode should to my understanding ask the user if a retry should be tried which will most likely succeed unless a bad mirror is used or there is a severe problem on the server. However, in non-interactive mode I guess zypper will not automatically retry. I do not know why this issue is assigned to i@marguerite.su but I guess the zypper bugowners would be a better match.
Comment 2 Michael Andres 2018-07-30 07:44:01 UTC
> A 502 Bad Gateway indicates that the edge server (server acting as a proxy)
> was not able to get a valid or any response from the origin server (also
> called upstream server).

Looks like this occurs in VMs more often. We can only try to mitigate the impact. Oliver addressed this in https://github.com/openSUSE/zypper/issues/177.
Comment 3 Benjamin Zeller 2018-07-31 10:12:11 UTC
https://github.com/openSUSE/libzypp/pull/129
Comment 4 Benjamin Zeller 2018-07-31 10:15:00 UTC
Fixed in libzypp >= 17.5.3
Comment 5 Michael Andres 2018-07-31 10:40:34 UTC
Fixed in:
  SLE-12-SP3      libzypp 16.17.18   
  SLE-12-SP2      libzypp 16.17.18   
  SLE-12-SP1      libzypp 15.25.15   
  SLE-12          libzypp 14.45.15
Comment 10 Swamp Workflow Management 2018-08-30 10:15:46 UTC
SUSE-SU-2018:2555-1: An update that solves four vulnerabilities and has 10 fixes is now available.

Category: security (important)
Bug References: 1037210,1038984,1045735,1048315,1054088,1070851,1076192,1088705,1091624,1092413,1096803,1100028,1101349,1102429
CVE References: CVE-2017-7435,CVE-2017-7436,CVE-2017-9269,CVE-2018-7685
Sources used:
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    libzypp-15.25.17-46.22.1, zypper-1.12.59-46.10.1
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    libzypp-15.25.17-46.22.1, zypper-1.12.59-46.10.1
Comment 13 Swamp Workflow Management 2018-09-11 16:10:27 UTC
SUSE-SU-2018:2688-1: An update that solves four vulnerabilities and has 13 fixes is now available.

Category: security (important)
Bug References: 1036304,1037210,1038984,1045735,1048315,1054088,1070851,1076192,1079334,1088705,1091624,1092413,1096803,1099847,1100028,1101349,1102429
CVE References: CVE-2017-7435,CVE-2017-7436,CVE-2017-9269,CVE-2018-7685
Sources used:
SUSE Linux Enterprise Server 12-LTSS (src):    libzypp-14.45.17-2.82.1, zypper-1.11.70-2.69.2
Comment 14 Swamp Workflow Management 2018-09-11 19:09:39 UTC
SUSE-SU-2018:2690-1: An update that solves two vulnerabilities and has 26 fixes is now available.

Category: security (important)
Bug References: 1036304,1041178,1043166,1045735,1058515,1066215,1070770,1070851,1082318,1084525,1088037,1088705,1091624,1092413,1093103,1096217,1096617,1096803,1099847,1100028,1100095,1100427,1101349,1102019,1102429,408814,428822,907538
CVE References: CVE-2017-9269,CVE-2018-7685
Sources used:
SUSE Linux Enterprise Module for Development Tools 15 (src):    libsolv-0.6.35-3.5.2
SUSE Linux Enterprise Module for Basesystem 15 (src):    libsolv-0.6.35-3.5.2, libzypp-17.6.4-3.10.1, zypper-1.14.10-3.7.1
Comment 15 Swamp Workflow Management 2018-09-14 16:11:56 UTC
SUSE-SU-2018:2716-1: An update that solves two vulnerabilities and has 12 fixes is now available.

Category: security (important)
Bug References: 1036304,1045735,1049825,1070851,1076192,1079334,1088705,1091624,1092413,1096803,1099847,1100028,1101349,1102429
CVE References: CVE-2017-9269,CVE-2018-7685
Sources used:
SUSE OpenStack Cloud 7 (src):    libzypp-16.17.20-27.52.1, zypper-1.13.45-18.33.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    libzypp-16.17.20-27.52.1, zypper-1.13.45-18.33.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    libzypp-16.17.20-27.52.1, zypper-1.13.45-18.33.1
SUSE Enterprise Storage 4 (src):    libzypp-16.17.20-27.52.1, zypper-1.13.45-18.33.1
OpenStack Cloud Magnum Orchestration 7 (src):    libzypp-16.17.20-27.52.1, zypper-1.13.45-18.33.1
Comment 16 Swamp Workflow Management 2018-09-17 10:09:27 UTC
openSUSE-SU-2018:2739-1: An update that solves two vulnerabilities and has 26 fixes is now available.

Category: security (important)
Bug References: 1036304,1041178,1043166,1045735,1058515,1066215,1070770,1070851,1082318,1084525,1088037,1088705,1091624,1092413,1093103,1096217,1096617,1096803,1099847,1100028,1100095,1100427,1101349,1102019,1102429,408814,428822,907538
CVE References: CVE-2017-9269,CVE-2018-7685
Sources used:
openSUSE Leap 15.0 (src):    libsolv-0.6.35-lp150.2.3.1, libzypp-17.6.4-lp150.2.3.1, zypper-1.14.10-lp150.2.3.1
Comment 17 Swamp Workflow Management 2018-09-24 10:13:13 UTC
SUSE-SU-2018:2814-1: An update that solves two vulnerabilities and has 11 fixes is now available.

Category: security (important)
Bug References: 1036304,1045735,1049825,1070851,1076192,1088705,1091624,1092413,1096803,1099847,1100028,1101349,1102429
CVE References: CVE-2017-9269,CVE-2018-7685
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    libzypp-16.17.20-2.33.2
SUSE Linux Enterprise Server 12-SP3 (src):    libzypp-16.17.20-2.33.2, zypper-1.13.45-21.21.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    libzypp-16.17.20-2.33.2, zypper-1.13.45-21.21.2
SUSE CaaS Platform ALL (src):    libzypp-16.17.20-2.33.2, zypper-1.13.45-21.21.2
SUSE CaaS Platform 3.0 (src):    libzypp-16.17.20-2.33.2, zypper-1.13.45-21.21.2
Comment 18 Swamp Workflow Management 2018-09-26 16:23:19 UTC
openSUSE-SU-2018:2881-1: An update that solves one vulnerability and has 11 fixes is now available.

Category: security (important)
Bug References: 1036304,1049825,1070851,1076192,1088705,1091624,1092413,1096803,1099847,1100028,1101349,1102429
CVE References: CVE-2018-7685
Sources used:
openSUSE Leap 42.3 (src):    libzypp-16.17.20-27.1, zypper-1.13.45-20.1
Comment 19 Swamp Workflow Management 2018-10-18 17:14:55 UTC
SUSE-SU-2018:2716-2: An update that solves two vulnerabilities and has 12 fixes is now available.

Category: security (important)
Bug References: 1036304,1045735,1049825,1070851,1076192,1079334,1088705,1091624,1092413,1096803,1099847,1100028,1101349,1102429
CVE References: CVE-2017-9269,CVE-2018-7685
Sources used:
SUSE Linux Enterprise Server 12-SP2-BCL (src):    libzypp-16.17.20-27.52.1, zypper-1.13.45-18.33.1