Bug 1069962 - Tumbleweed: OpenSuse's Firefox version crashes when "cancel" pressed in "File Upload" dialogue, e.g. TYPO3, BUGZILLA
Tumbleweed: OpenSuse's Firefox version crashes when "cancel" pressed in "File...
Status: RESOLVED FIXED
: 1069961 1074272 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Firefox
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Wolfgang Rosenauer
E-mail List
:
Depends on: 1069961
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-27 15:27 UTC by Michael from Offenbach Germany
Modified: 2018-01-05 00:42 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael from Offenbach Germany 2017-11-27 15:27:27 UTC
+++ This bug was initially created as a clone of Bug #1069961 +++

Resolved Fixed in Leap 42.2. Fine in stable Firefox 52.5, as of yesterday.

Reintroduction of Bug 1015998 for
- Firefox 57.0 from repo mozilla/openSUSE_Leap_42.3

I've chatted about this in #SUSE, it's confirmed that this bug is also existing for Tumbleweed and repo mozilla:Factory



(Current issue cloned for Tumbleweed)
Comment 1 Andreas Stieger 2017-11-27 16:18:16 UTC
*** Bug 1069961 has been marked as a duplicate of this bug. ***
Comment 2 Wolfgang Rosenauer 2017-12-16 21:09:34 UTC
Please test the latest package in the mozilla repository and report if it helped.
Comment 3 Michael from Offenbach Germany 2017-12-17 14:52:17 UTC
Hallo Wolfgang,


upgraded again from 52.X ESR version to 57.0.1, for testing. No change, still crashing. Tested here in bugzilla (Add an attachment, Browse, Cancel).

BUT MAYBE we might have a version conflict, what version do you exactly mean when you ask for "test the latest package in the mozilla repository" 

As I'm on Leap 42.3, not on TW, I only wanted to use the much faster newer Firefox releases, my "mozilla" repo is http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3

And from this repo my installed Firefox is now 57.0.1-3.1.

Is this the version you've expected to be tested?
Comment 4 Michael from Offenbach Germany 2017-12-17 15:38:27 UTC
can't find a "zypper" flag in man page for pkg timestamp information, so checked with browser: MozillaFirefox-57.0.1-3.1.x86_64.rpm is from 16-Dec-2017 17:57, so should be most recent.

I'll wait now for your next advice.
Comment 5 Wolfgang Rosenauer 2017-12-17 16:02:01 UTC
57.0.1-3.1 is the most recent and would contain the change I hoped would fix the issue.

Actually in my test VM with KDE I do not experience any crash when I open and cancel the file dialog via "open file". Is that different? You are testing with a download save dialog instead of my "open file".
Comment 6 Michael from Offenbach Germany 2017-12-17 17:12:46 UTC
I've tested it in the current Firefox 57.0.1 Bugzilla session for this bug:

- clicked on "Add an attachment (proposed patch, testcase, etc.)"

- below "File: Enter the path to the file on your computer (or paste text as attachment)" is a "Durchsuchen" button (guess "Search for", my OpenSuse/Firefox is German).

- when clicking "Durchsuchen", a KDE/Dolphin style "Datei hochladen" ("upload file") dialogue box opens 

- clicking on "Abbrechen" ("cancel") results in the described immediate crash
Comment 7 Fabian Vogt 2018-01-01 22:19:50 UTC
*** Bug 1074272 has been marked as a duplicate of this bug. ***
Comment 8 Fabian Vogt 2018-01-01 22:42:55 UTC
This seems to be reproducible only with e10s enabled.

I tried to debug the issue by running firefox with valgrind, but unfortunately that only works without e10s.

Can anyone confirm that firefox does not crash after setting "browser.tabs.remote.autostart" and "browser.tabs.remote.autostart2" in about:config to false (and restarting firefox)?
Comment 9 Fabian Vogt 2018-01-02 18:06:39 UTC
It's indeed caused by the broken patch which removed the NS_ADDREF_THIS() call.

https://build.opensuse.org/package/rdiff/home:Vogtinator:branches:mozilla:Factory/MozillaFirefox?opackage=MozillaFirefox&oproject=mozilla%3AFactory&rev=4

works for me.
Comment 10 Wolfgang Rosenauer 2018-01-03 09:02:35 UTC
Thanks for trying it out. I have to say that I'm confused about the actual scope locations of the ADDREF and REMOVE but if you confirmed it to work.

A new version is currently building in the mozilla repo. Resulting version should be >= 57.0.3 (currently there still is 57.0.1 in that repo).

Would be nice if someone else can also retest before I submit to TW/Factory.
Comment 11 Wolfgang Rosenauer 2018-01-03 13:45:39 UTC
Tested myself already and submitted to Factory.
Please reopen if it still is a problem.
Comment 12 Swamp Workflow Management 2018-01-03 14:20:06 UTC
This is an autogenerated message for OBS integration:
This bug (1069962) was mentioned in
https://build.opensuse.org/request/show/561348 Factory / MozillaFirefox
Comment 13 Swamp Workflow Management 2018-01-04 23:00:06 UTC
This is an autogenerated message for OBS integration:
This bug (1069962) was mentioned in
https://build.opensuse.org/request/show/561754 Factory / MozillaFirefox
Comment 14 Michael from Offenbach Germany 2018-01-05 00:42:46 UTC
I've tested also with 57.0.4 from mozilla/openSUSE_Leap_42.3, works fine!

Many thanks to Wolfgang and all others who eliminated this bug !!!