Bug 1065956 - (CVE-2017-15535) VUL-0: CVE-2017-15535: mongodb: a disabled-by-defaultconfiguration setting, networkMessageCompressors (aka wire protocolcompression) if enabled could lead to denial of service
(CVE-2017-15535)
VUL-0: CVE-2017-15535: mongodb: a disabled-by-defaultconfiguration setting, ...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Network
Leap 42.3
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Alberto Planas Dominguez
E-mail List
https://smash.suse.de/issue/194352/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-01 08:44 UTC by Victor Pereira
Modified: 2018-02-26 15:19 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Pereira 2017-11-01 08:44:59 UTC
CVE-2017-15535

MongoDB 3.4.x before 3.4.10, and 3.5.x-development, has a disabled-by-default
configuration setting, networkMessageCompressors (aka wire protocol
compression), which exposes a vulnerability when enabled that could be exploited
by a malicious attacker to deny service or modify memory.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-15535
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15535
https://jira.mongodb.org/browse/SERVER-31273
Comment 1 Bernhard Wiedemann 2017-11-02 11:00:41 UTC
This is an autogenerated message for OBS integration:
This bug (1065956) was mentioned in
https://build.opensuse.org/request/show/538314 42.3+Backports:SLE-12-SP2 / mongodb
Comment 2 Andreas Stieger 2017-11-15 10:56:13 UTC
done
Comment 3 Swamp Workflow Management 2017-11-15 14:07:29 UTC
openSUSE-SU-2017:3018-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1065956
CVE References: CVE-2017-15535
Sources used:
openSUSE Leap 42.3 (src):    mongodb-3.4.10-3.1
Comment 4 Swamp Workflow Management 2017-11-15 14:09:30 UTC
openSUSE-SU-2017:3022-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1065956
CVE References: CVE-2017-15535
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    mongodb-3.4.10-5.1