Bug 1057241 - kernel BUG at ../drivers/gpu/drm/ttm/ttm_bo_util.c:589
kernel BUG at ../drivers/gpu/drm/ttm/ttm_bo_util.c:589
Status: RESOLVED FIXED
: 1057449 1062045 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P1 - Urgent : Normal (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-05 14:06 UTC by Andreas Schwab
Modified: 2022-03-04 20:11 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schwab 2017-09-05 14:06:03 UTC
This is causing plymouthd to hang in D and blocking reboots.

[    6.858736] ------------[ cut here ]------------
[    6.858741] kernel BUG at ../drivers/gpu/drm/ttm/ttm_bo_util.c:589!
[    6.858744] invalid opcode: 0000 [#1] PREEMPT SMP
[    6.858745] Modules linked in: snd_hda_codec_generic snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm snd_seq snd_seq_device crct10dif_pclmul crc32_pclmul snd_timer crc32c_intel ghash_clmulni_intel snd pcbc aesni_intel soundcore virtio_balloon virtio_net ppdev parport_pc parport pvpanic aes_x86_64 crypto_simd i2c_piix4 joydev pcspkr glue_helper cryptd tpm_tis tpm_tis_core tpm button hid_generic usbhid floppy virtio_rng serio_raw qxl drm_kms_helper syscopyarea sysfillrect sysimgblt uhci_hcd fb_sys_fops ttm drm ehci_hcd usbcore ata_generic virtio_blk ata_piix sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua
[    6.858768] CPU: 1 PID: 310 Comm: plymouthd Not tainted 4.12.9-1-default #1
[    6.858769] Hardware name: Bochs Bochs, BIOS Bochs 01/01/2011
[    6.858770] task: ffff8869371d6100 task.stack: ffffa8bec07d0000
[    6.858776] RIP: 0010:ttm_bo_kmap+0x1d0/0x220 [ttm]
[    6.858777] RSP: 0018:ffffa8bec07d3c18 EFLAGS: 00010283
[    6.858778] RAX: ffff88697a192890 RBX: ffff8869793d4400 RCX: ffff8869793d4690
[    6.858779] RDX: 0000000000000300 RSI: 0000000000000000 RDI: ffff8869793d4458
[    6.858780] RBP: ffffa8bec07d3ca0 R08: 0000000000010004 R09: 0000000000000400
[    6.858781] R10: ffff8869793d4528 R11: 0000000000000000 R12: ffff8869798326b0
[    6.858782] R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000008
[    6.858783] FS:  00007fccc89d2840(0000) GS:ffff88697fd00000(0000) knlGS:0000000000000000
[    6.858784] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    6.858785] CR2: 00007fccc508a000 CR3: 000000007a2ea000 CR4: 00000000000406e0
[    6.858788] Call Trace:
[    6.858798]  ? qxl_bo_kunmap_atomic_page+0x5b/0x90 [qxl]
[    6.858801]  qxl_bo_kmap+0x3d/0x60 [qxl]
[    6.858804]  qxl_draw_dirty_fb+0x1ba/0x3e0 [qxl]
[    6.858808]  qxl_framebuffer_surface_dirty+0x86/0xc0 [qxl]
[    6.858821]  drm_mode_dirtyfb_ioctl+0x163/0x1a0 [drm]
[    6.858828]  drm_ioctl+0x1dd/0x430 [drm]
[    6.858835]  ? drm_mode_getfb+0xf0/0xf0 [drm]
[    6.858842]  do_vfs_ioctl+0x8d/0x5d0
[    6.858860]  ? wake_up_q+0x70/0x70
[    6.858862]  SyS_ioctl+0x74/0x80
[    6.858866]  entry_SYSCALL_64_fastpath+0x1e/0xa9
[    6.858872] RIP: 0033:0x7fccc80bb507
[    6.858872] RSP: 002b:00007ffe4d4b0c78 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[    6.858874] RAX: ffffffffffffffda RBX: 0000563e345b6a60 RCX: 00007fccc80bb507
[    6.858874] RDX: 00007ffe4d4b0cb0 RSI: 00000000c01864b1 RDI: 0000000000000009
[    6.858875] RBP: 0000000000000000 R08: 00007fccc4f4671c R09: 0000000000000186
[    6.858876] R10: 00007fccc4f458e4 R11: 0000000000000246 R12: 00007ffe4d4b0f48
[    6.858877] R13: 00000000ffffffff R14: 0000000000000000 R15: 00007fccc87b8510
[    6.858878] Code: 80 e8 b5 f9 ff ff c7 45 10 02 00 00 00 49 03 5e 18 48 89 c1 8b 74 24 08 31 d2 48 89 df e8 f9 3b 02 da 48 89 45 00 e9 fb fe ff ff <0f> 0b 4b 8d 7c 2c 58 e8 24 11 58 da e9 b7 fe ff ff 4b 8d 7c 2c 
[    6.858896] RIP: ttm_bo_kmap+0x1d0/0x220 [ttm] RSP: ffffa8bec07d3c18
[    6.858900] ---[ end trace 9dfc528eec060903 ]---
Comment 1 Takashi Iwai 2017-09-05 15:57:58 UTC
Seems like an upstream issue, hitting other distros, too.
Comment 2 Bruce Rogers 2017-09-08 19:47:03 UTC
*** Bug 1057449 has been marked as a duplicate of this bug. ***
Comment 4 Takashi Iwai 2017-09-21 20:46:50 UTC
The tentative fix is submitted to SLE15 and stable branches now.
Comment 5 Bruce Rogers 2017-10-02 21:15:22 UTC
*** Bug 1061176 has been marked as a duplicate of this bug. ***
Comment 6 Stefan Dirsch 2017-10-06 12:41:14 UTC
*** Bug 1062045 has been marked as a duplicate of this bug. ***