Bug 1055759 - Kolourpaint can not save any image: serviceType "QImageIOPlugins" not found
Kolourpaint can not save any image: serviceType "QImageIOPlugins" not found
Status: RESOLVED FIXED
: 1080429 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-25 18:10 UTC by Mindaugas Baranauskas
Modified: 2019-06-06 14:44 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
screenshot (70.90 KB, image/png)
2017-08-25 18:10 UTC, Mindaugas Baranauskas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mindaugas Baranauskas 2017-08-25 18:10:58 UTC
Created attachment 738355 [details]
screenshot

I just installed openSUSE Tumbleweed with LXQT. I also installed Kolourpaint program. But this program fails to save images. See output in console:



> LANG=C
vardenis@localhost:~> kolourpaint 
The desktop entry file "/opt/kde3/share/applications/kde/kresources.desktop" has Type= "Application" but also has a X-KDE-Library key. This works for now, but makes user-preference handling difficult, so support for this might be removed at some point. Consider splitting it into two desktop files.
No file found for ".xml" , even though update-mime-info said it would exist.
Either it was just removed, or the directory doesn't have executable permission... ("/usr/share/mime")
kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find ""
kf5.kio.core: We got some errors while running 'net usershare info'
kf5.kio.core: "Failed to init messaging context\n"
kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find ""
KServiceTypeTrader: serviceType "QImageIOPlugins" not found
Comment 1 Mindaugas Baranauskas 2017-08-25 18:11:39 UTC
> LANG=C
vardenis@localhost:~> rpm -qi kolourpaint
Name        : kolourpaint
Version     : 17.04.3
Release     : 1.1
Architecture: i586
Install Date: Fri Aug 25 19:47:09 2017
Group       : Productivity/Graphics/Bitmap Editors
Size        : 1939234
License     : BSD-2-Clause and LGPL-2.1+ and GFDL-1.2+ and GPL-2.0
Signature   : RSA/SHA256, Sat Jul 29 10:50:19 2017, Key ID b88b2fd43dbdc284
Source RPM  : kolourpaint-17.04.3-1.1.src.rpm
Build Date  : Sat Jul 15 15:00:00 2017
Build Host  : lamb57
Relocations : (not relocatable)
Packager    : https://bugs.opensuse.org
Vendor      : openSUSE
URL         : http://www.kde.org
Summary     : Paint Program
Description :
Paint program for KDE
Distribution: openSUSE Tumbleweed
Comment 2 Mindaugas Baranauskas 2017-08-25 18:13:41 UTC
Related packages seems to be already installed:

> zypper se -f QImageIOPlugins
Loading repository data...
Reading installed packages...

S  | Name             | Summary                     | Type   
---+------------------+-----------------------------+--------
i  | kdebase4-runtime | The KDE Runtime Components  | package
i  | kdelibs4         | KDE Base Libraries          | package
i+ | kimageformats    | Image format plugins for Qt | package
Comment 3 Wolfgang Bauer 2017-08-25 18:40:18 UTC
Install kdelibs4support, that should fix it.
Comment 4 Wolfgang Bauer 2018-02-12 14:19:47 UTC
*** Bug 1080429 has been marked as a duplicate of this bug. ***
Comment 5 Swamp Workflow Management 2019-05-22 17:50:07 UTC
This is an autogenerated message for OBS integration:
This bug (1055759) was mentioned in
https://build.opensuse.org/request/show/704813 15.0+42.3+Backports:SLE-12-SP2+Backports:SLE-12-SP3+Backports:SLE-15 / kolourpaint
Comment 6 Swamp Workflow Management 2019-06-05 19:14:22 UTC
openSUSE-RU-2019:1511-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1055759
CVE References: 
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    kolourpaint-16.08.2-5.1, kolourpaint-17.04.2-5.1
Comment 7 Swamp Workflow Management 2019-06-05 19:17:00 UTC
openSUSE-RU-2019:1511-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1055759
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    kolourpaint-17.04.2-2.3.3
openSUSE Leap 15.0 (src):    kolourpaint-17.12.3-lp150.2.3.1
openSUSE Backports SLE-15 (src):    kolourpaint-17.12.3-bp150.3.3.1
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    kolourpaint-16.08.2-5.1, kolourpaint-17.04.2-5.1
Comment 8 Wolfgang Bauer 2019-06-06 09:04:03 UTC
A dependency has been added to kolourpaint meanwhile in all supported openSUSE versions.