Bug 1045719 - (CVE-2017-9775) VUL-0: CVE-2017-9775: poppler: DoS stack buffer overflow in GfxState.cc in pdftocairo via a crafted PDF document
(CVE-2017-9775)
VUL-0: CVE-2017-9775: poppler: DoS stack buffer overflow in GfxState.cc in pd...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Peter Simons
Security Team bot
https://smash.suse.de/issue/187239/
CVSSv2:SUSE:CVE-2017-9775:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 08:56 UTC by Alexander Bergmann
Modified: 2017-08-05 16:10 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2017-06-23 08:56:15 UTC
CVE-2017-9775

Stack buffer overflow in GfxState.cc in pdftocairo in Poppler before 0.56 allows
remote attackers to cause a denial of service (application crash) via a crafted
PDF document.

Upstream Fix:
https://cgit.freedesktop.org/poppler/poppler/commit/?id=8f4ff8243a3d599ff2a6c08b1da389e606ba4fc9

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-9775
http://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-9775.html
http://www.cvedetails.com/cve/CVE-2017-9775/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9775
https://bugs.freedesktop.org/show_bug.cgi?id=101540
Comment 2 Swamp Workflow Management 2017-07-28 19:09:27 UTC
SUSE-SU-2017:1998-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1042802,1045719,1045721
CVE References: CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    poppler-0.24.4-14.6.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    poppler-0.24.4-14.6.1
SUSE Linux Enterprise Server 12-SP2 (src):    poppler-0.24.4-14.6.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    poppler-0.24.4-14.6.1
Comment 3 Swamp Workflow Management 2017-07-28 19:10:27 UTC
SUSE-SU-2017:1999-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1041783,1042802,1042803,1043088,1045719,1045721
CVE References: CVE-2017-7511,CVE-2017-7515,CVE-2017-9406,CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
Comment 4 Andreas Stieger 2017-08-05 13:04:54 UTC
done
Comment 5 Swamp Workflow Management 2017-08-05 16:10:04 UTC
openSUSE-SU-2017:2056-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1041783,1042802,1042803,1043088,1045719,1045721
CVE References: CVE-2017-7511,CVE-2017-7515,CVE-2017-9406,CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
openSUSE Leap 42.3 (src):    poppler-0.43.0-5.1, poppler-qt-0.43.0-5.1, poppler-qt5-0.43.0-5.1
openSUSE Leap 42.2 (src):    poppler-0.43.0-2.3.1, poppler-qt-0.43.0-2.3.1, poppler-qt5-0.43.0-2.3.1