Bug 1043088 - (CVE-2017-7515) VUL-0: CVE-2017-7515: poppler: Stack exhaustion due to infinite recursive call in pdfunite
(CVE-2017-7515)
VUL-0: CVE-2017-7515: poppler: Stack exhaustion due to infinite recursive cal...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Minor
: ---
Assigned To: Peter Simons
Security Team bot
https://smash.suse.de/issue/186306/
CVSSv2:SUSE:CVE-2017-7515:1.7:(AV:L/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 10:04 UTC by Victor Pereira
Modified: 2019-11-08 01:10 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Pereira 2017-06-07 10:04:07 UTC
rh#1459066

poppler through version 0.55.0 is vulnerable to an uncontrolled recursion in
pdfunite resulting into potential denial-of-service.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1459066
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-7515
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7515
https://bugs.freedesktop.org/show_bug.cgi?id=101208
https://bugs.freedesktop.org/show_bug.cgi%3Fid=101208
Comment 7 Swamp Workflow Management 2017-07-28 19:10:18 UTC
SUSE-SU-2017:1999-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1041783,1042802,1042803,1043088,1045719,1045721
CVE References: CVE-2017-7511,CVE-2017-7515,CVE-2017-9406,CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
Comment 8 Swamp Workflow Management 2017-08-05 16:09:56 UTC
openSUSE-SU-2017:2056-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1041783,1042802,1042803,1043088,1045719,1045721
CVE References: CVE-2017-7511,CVE-2017-7515,CVE-2017-9406,CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
openSUSE Leap 42.3 (src):    poppler-0.43.0-5.1, poppler-qt-0.43.0-5.1, poppler-qt5-0.43.0-5.1
openSUSE Leap 42.2 (src):    poppler-0.43.0-2.3.1, poppler-qt-0.43.0-2.3.1, poppler-qt5-0.43.0-2.3.1
Comment 9 Peter Simons 2017-08-07 09:36:41 UTC
An update that fixes this issue is available.
Comment 10 Swamp Workflow Management 2019-10-16 12:50:11 UTC
This is an autogenerated message for OBS integration:
This bug (1043088) was mentioned in
https://build.opensuse.org/request/show/738876 Backports:SLE-15-SP1 / poppler-qt5
Comment 11 Swamp Workflow Management 2019-11-06 11:10:11 UTC
This is an autogenerated message for OBS integration:
This bug (1043088) was mentioned in
https://build.opensuse.org/request/show/745853 Backports:SLE-15-SP1 / poppler-qt5
Comment 12 Swamp Workflow Management 2019-11-08 01:10:11 UTC
This is an autogenerated message for OBS integration:
This bug (1043088) was mentioned in
https://build.opensuse.org/request/show/746440 Backports:SLE-15-SP1 / poppler-qt5