Bug 1042802 - (CVE-2017-9408) VUL-0: CVE-2017-9408: poppler: Memory leak in the Object::initArray function
(CVE-2017-9408)
VUL-0: CVE-2017-9408: poppler: Memory leak in the Object::initArray function
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Minor
: ---
Assigned To: Peter Simons
Security Team bot
https://smash.suse.de/issue/186225/
CVSSv3:RedHat:CVE-2017-9408:3.3:(AV:L...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 06:10 UTC by Victor Pereira
Modified: 2017-08-05 16:09 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Pereira 2017-06-06 06:10:30 UTC
rh#1458702

In Poppler 0.54.0, a memory leak vulnerability was found in the function
Object::initArray in Object.cc, which allows attackers to cause a denial of
service via a crafted file.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1458702
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-9408
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9408
https://bugs.freedesktop.org/show_bug.cgi?id=100776
Comment 1 Marcus Meissner 2017-06-13 16:06:59 UTC
was not in current submissions?
Comment 2 Peter Simons 2017-07-19 11:26:14 UTC
This issue was fixed in the previous update by 0001-Fix-memory-leak-when-reconstructing-broken-files.patch. Unfortunately, the change log entry mis-declares the bsc number, claiming that patch would fix bsc#1040170, which is in fact still open (and has no known fix as of today).
Comment 3 Swamp Workflow Management 2017-07-28 19:09:19 UTC
SUSE-SU-2017:1998-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1042802,1045719,1045721
CVE References: CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    poppler-0.24.4-14.6.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    poppler-0.24.4-14.6.1
SUSE Linux Enterprise Server 12-SP2 (src):    poppler-0.24.4-14.6.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    poppler-0.24.4-14.6.1
Comment 4 Swamp Workflow Management 2017-07-28 19:10:02 UTC
SUSE-SU-2017:1999-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1041783,1042802,1042803,1043088,1045719,1045721
CVE References: CVE-2017-7511,CVE-2017-7515,CVE-2017-9406,CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Server 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    poppler-0.43.0-16.5.1, poppler-qt-0.43.0-16.5.1
Comment 5 Andreas Stieger 2017-08-05 13:04:53 UTC
done
Comment 6 Swamp Workflow Management 2017-08-05 16:09:41 UTC
openSUSE-SU-2017:2056-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1041783,1042802,1042803,1043088,1045719,1045721
CVE References: CVE-2017-7511,CVE-2017-7515,CVE-2017-9406,CVE-2017-9408,CVE-2017-9775,CVE-2017-9776
Sources used:
openSUSE Leap 42.3 (src):    poppler-0.43.0-5.1, poppler-qt-0.43.0-5.1, poppler-qt5-0.43.0-5.1
openSUSE Leap 42.2 (src):    poppler-0.43.0-2.3.1, poppler-qt-0.43.0-2.3.1, poppler-qt5-0.43.0-2.3.1