Bug 1032754 - Akregator fails to start after latest messagelib update
Akregator fails to start after latest messagelib update
Status: RESOLVED FIXED
: 1032809 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: KDE Applications
Leap 42.2
x86-64 openSUSE 42.2
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-06 15:39 UTC by Wolfgang Bauer
Modified: 2017-04-07 13:13 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Bauer 2017-04-06 15:39:22 UTC
Error message:
akregator: symbol lookup error: /usr/lib64/libakregatorprivate.so.5: undefined symbol: _ZN15WebEngineViewer13WebEngineView14dragEnterEventEP15QDragEnterEvent

blogilo has a similar problem.

To fix it, kdepim needs to be rebuilt against the latest messagelib update.

I didn't notice this because kmail, the other user of messagelib, works fine... :-(
Comment 1 Wolfgang Bauer 2017-04-06 15:42:09 UTC
@Maintenance team: Can you take care of releasing a kdepim update please? (no changes needed, it just has to be rebuilt)
Or shall I submit an update?
Comment 2 Andreas Stieger 2017-04-06 18:31:51 UTC
Rebuild triggered in openSUSE:Maintenance:6611. Test packages will appear in:
http://download.opensuse.org/repositories/openSUSE:/Maintenance:/6611/
http://download.opensuse.org/update/leap/42.2-test/

Please verify.
Comment 3 Wolfgang Bauer 2017-04-06 22:21:25 UTC
Yes, the packages in http://download.opensuse.org/repositories/openSUSE:/Maintenance:/6611/ work fine with the updated messagelib installed (and also with the old one).

Thank you!
Comment 4 Neil Rickert 2017-04-07 00:11:07 UTC
*** Bug 1032809 has been marked as a duplicate of this bug. ***
Comment 5 Andreas Stieger 2017-04-07 07:18:34 UTC
Thanks for verifying. I released the rebuilt packages, closing.
Comment 6 Swamp Workflow Management 2017-04-07 13:13:10 UTC
openSUSE-RU-2017:0965-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1032754
CVE References: 
Sources used:
openSUSE Leap 42.2 (src):    kdepim-16.08.2-2.2.1