Bug 1017471 - Kernel 4.9.0-2 network issue
Kernel 4.9.0-2 network issue
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P3 - Medium : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-29 06:38 UTC by John Shand
Modified: 2017-03-24 20:45 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
Larry.Finger: needinfo? (jshand2013)


Attachments
dmesg output for failure of rtl8192ce with default parameters (843 bytes, text/plain)
2017-01-29 22:40 UTC, H. Zeng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Shand 2016-12-29 06:38:24 UTC
User-Agent:       Mozilla/5.0 (Linux; Android 4.4.2; HUAWEI Y221-U53 Build/HUAWEIY221-U53) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.85 Mobile Safari/537.36
Build Identifier: 

I have a rtl8192ce realtek wireless pcie card. After this update I am unable to either connect to and or remain connected to ADSL router. This needs to be fixed as I have been unable to use the Internet all day




Reproducible: Always
Comment 1 Takashi Iwai 2016-12-29 14:03:27 UTC
Just to be sure, the system still works fine when you boot with the older 4.8.x kernel, right?
Comment 2 John Shand 2017-01-02 22:10:30 UTC
yes it still works with the 4.8.x kernel
Comment 3 Takashi Iwai 2017-01-09 21:50:29 UTC
Larry, do you know of this regression?
Comment 4 Larry Finger 2017-01-09 22:37:53 UTC
No. I do not use openSUSE kernels other than the default; however, I used all of the mainline 4.9 kernels during development.

Are there any situations listed in the output of dmesg?
Comment 5 John Shand 2017-01-13 02:40:41 UTC
when i installed the recent dvd image, the wifi driver kept loosing or dropping the connection with the open AP.  as for dmesg, it doesn't seem to show anything unusual
Comment 6 H. Zeng 2017-01-14 22:39:53 UTC
I am experiencing the same problem. Before I come here, I asked for help in the forum (https://forums.opensuse.org/showthread.php/521989-Wireless-cannot-connect-after-dup-to-kernel-4-9-0-1-2-yesterday), and kept searching for a solution.

The wireless connection will work with kernel 4.9.0-2 if some extra modprobe options are set, although the connection is unstable because of high latency (100ms~2000ms) and high package loss (15%~60%). The working options are,
`
options rtl8192ce ips=1 fwlps=0 swlps=1
`

And I found that it's the `fwlps` (default 1) option made the connection fail.

I tried the new stable kernel-default version 4.9.3 from https://software.opensuse.org/package/kernel-default, and the problem was still the same. But kernel-default 4.8.14 works well as before.

P.S. In case it's helpful, some outputs of dmesg and journalctl are listed in the post in the forum, specificly #1, #3 and #6 sub-posts of the post.
Comment 7 Benedikt Geißler 2017-01-17 22:14:02 UTC
I also had this problem with an rtl8188ce wifi card in a Thinkpad X220 after the upgrade from Linux 4.8.x to 4.9.0-2 two weeks and also made it work again by disabling the power save features like H. Zeng did. Interestingly the Debian wiki helped me with this: https://wiki.debian.org/rtl819x#rtl8192ce ;)
Comment 8 H. Zeng 2017-01-27 22:05:06 UTC
Although the kernel is updated to 4.9.5, I am still having this problem. This issue is annoying because it affects the network speed a lot. Could anyone look into this issue for a better solution?

The workaround mentioned in Comment 6 works well when the signal is strong enough. But when the signal is not so strong, there will be a large latency and/or package loss with the connection when pinging the wireless router.
Comment 9 Larry Finger 2017-01-29 20:05:42 UTC
I retested rtl8192ce under kernel 4.10-rc5. It had no connection drops in 8 hours of normal usage including zypper updates of my Leap 42.2 system, and two different TW installations in VirtualBox VMs. Downloads of the updates reached 4 MB/s, which is the limit of my broadband connection. I used only the default values for the module parameters. The signal strength of my AP was -58 dBm, which is not strong.

There was a power-save problem, but that was fixed in kernel 4.9.4-2. 

In short I cannot duplicate the problem. Have you tried the Kernel of the Day (KOTD)? See https://en.opensuse.org/openSUSE:Kernel_of_the_day for instructions.
Comment 10 H. Zeng 2017-01-29 22:40:40 UTC
Created attachment 712005 [details]
dmesg output for failure of rtl8192ce with default parameters

NOTE: mac address replaced with <MAC>
Comment 11 H. Zeng 2017-01-29 22:48:09 UTC
I just tried kernel-default-4.10.rc5. It looks like the situation is the same as that with kernel 4.9.5: 
- Default parameters will not work
- Set `fwlps=0` make it work but with around 10% package loss when pinging local router
* Signal strength is -52dBm.

TL;DR
=====
1. Install and boot into kernel-default-4.10.rc5-2.1.gc67d673
2. Remove custom options for rtl8192ce /etc/modprobe.d/rtl8192ce.conf
3. Reload module rtl8192ce
4. Results:
Pinging router gets,
`--- 192.168.1.1 ping statistics ---
1000 packets transmitted, 907 received, 9% packet loss, time 1003724ms
rtt min/avg/max/mdev = 0.766/380.730/4612.383/563.338 ms, pipe 5`

But a second round could not finish because of error of "Network is unreachable".
`--- 192.168.1.1 ping statistics ---
1000 packets transmitted, 342 received, 65% packet loss, time 1033262ms
rtt min/avg/max/mdev = 1.009/716.540/4104.929/748.872 ms, pipe 5`

And the connection could not resume because of "IP configuration is unavailable".

This looks just the same as previous situation.

`dmesg` shows (mac address replaced with <MAC>), See Comment 10.

5. After setting custom option `ips=0`, the wireless connection works.

`--- 192.168.1.1 ping statistics ---
1000 packets transmitted, 916 received, 8% packet loss, time 1003449ms
rtt min/avg/max/mdev = 0.809/359.046/3953.933/531.613 ms, pipe 4`

And second round gets,
`--- 192.168.1.1 ping statistics ---
979 packets transmitted, 866 received, 11% packet loss, time 982401ms
rtt min/avg/max/mdev = 0.843/305.538/3589.854/525.753 ms, pipe 4`
Comment 12 H. Zeng 2017-01-29 23:00:51 UTC
Sorry, I made a mistake in Comment 11. Correct result is that either `ips=0` or `fwlps=0` makes the wireless work well with around 10% package loss.

P.S. I checked driver in use, getting,
`srcversion:     2342051B3DB62D6CF069F77`
It looks the same as that in kernel 4.9.5 for my case. I use TW with current snapshot, no modification.
Comment 13 Larry Finger 2017-01-30 02:12:26 UTC
By chance, a Debian user reported a problem that may affect you. In the edit of rtl8192ce, an error was introduced that caused loading of the wrong firmware for some models. Unfortunately, that error did not affect the model I have, thus I did not see the problem.

It will take some time for the fix to propagate through the system. Could you please try cloning the git repo at http://github.com/lwfinger/rtlwifi_new.git to see if that change fixes your problem?
Comment 14 H. Zeng 2017-01-30 18:12:14 UTC
I have tried the drive from the repo recommended by Larry Finger in Comment 13. It works great with kernel 4.9.5 and 4.9.6 in my case. With default parameters, the wireless network has low latency and almost 0 package loss.
Comment 15 John Shand 2017-02-19 07:24:28 UTC
this was fixed in 4.9.10
Comment 16 Andreas Stieger 2017-03-24 20:45:44 UTC
(In reply to John Shand from comment #15)
> this was fixed in 4.9.10

closing