Bug 1014167 - attempting to not install grub2 package in a "do not install any bootloader" configuration blocks TW installation
attempting to not install grub2 package in a "do not install any bootloader" ...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Installation
Leap 42.3
PC Other
: P5 - None : Major (vote)
: Leap 42.3
Assigned To: Gilson Souza
Jiri Srain
https://trello.com/c/MmMgmDZG
regression
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-07 09:05 UTC by Felix Miata
Modified: 2018-02-20 08:32 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2logs saved before proceeding past installation settings screen (891.01 KB, application/octet-stream)
2016-12-07 09:05 UTC, Felix Miata
Details
y2logs saved post-installation (1.30 MB, application/octet-stream)
2016-12-07 09:07 UTC, Felix Miata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2016-12-07 09:05:53 UTC
Created attachment 705249 [details]
y2logs saved before proceeding past installation settings screen

To reproduce:
1-start HTTP installation using Grub and 20161105 linux and initrd
2-select do not install any bootloader (no bootloader management)
3-set taboo on grub2, shim and os-prober packages
4-click install button on installation settings screen

Actual behavior:
1-Error window reports error that must be resolved before continuing
2-installation settings screen reports grub2 needs to be selected

Expected behavior:
1-installation proceeds without insisting on installing an unneeded and unwanted bootloader package

Notes:
1-42.2 worked as expected done the same way on 30 November, as did all similar previous installations of both Distribution and Tumbleweed since Grub ceased to be a bootloader option during installation.
2-I proceeded with the installation by leaving locks set on all grub2* packages other than grub2 and specifying /dev/null as the bootloader installation target
3-whether related or not I have no idea, but login was not allowed on first boot. I booted 42.2, chrooted into TW, executed passwd, and was able to boot into TW and login successfully.
4-rpm -e grub2 on first successful boot succeeded.
Comment 1 Felix Miata 2016-12-07 09:07:39 UTC
Created attachment 705250 [details]
y2logs saved post-installation
Comment 2 Imobach Gonzalez Sosa 2016-12-09 11:55:56 UTC
Josef, please, could you check if that's the expected behavior? Thank you!
Comment 3 Josef Reidinger 2016-12-12 08:26:44 UTC
Imo - this looks like bug as we allow this use case especially if someone want to use own bootloader.
Comment 4 Imobach Gonzalez Sosa 2016-12-12 08:48:14 UTC
Thanks Josef. I'm adding this bug report to our SCRUM queue so we can plan for it.
Comment 5 Felix Miata 2017-03-26 02:45:59 UTC
Proceeding to install from "Installation Settings" is still blocked by grub2 not selected for installation in TW 20170322.
Comment 6 Felix Miata 2017-03-27 19:23:25 UTC
This also applies to 42.3.
Comment 7 Gilson Souza 2017-08-14 10:02:56 UTC
Hi Felix,
yast-bootloader version 3.3.2 contains the fix for this issue. It will be released for SLE15 and TW. The pull request with the solution can be found here: https://github.com/yast/yast-bootloader/pull/454

Let me know if you need any additional information.

BR,
Gilson
Comment 8 Per Jessen 2017-10-29 19:13:25 UTC
*** Bug 1065588 has been marked as a duplicate of this bug. ***
Comment 9 Felix Miata 2017-11-25 06:45:32 UTC
TW20171123 installer demands grub2 be selected for installation even though do not install any bootloader is selected.
Comment 10 Gilson Souza 2017-12-18 08:47:46 UTC
Due storage-ng, yast-bootloader package could not be updated in TW yet.
Comment 11 Felix Miata 2018-02-20 00:21:26 UTC
Success to not install grub2 in TW20180218 x86_64. Only grub-0.97-204.6 installed.
Comment 12 Josef Reidinger 2018-02-20 08:32:50 UTC
thanks, so lets close