Bug 1012042 - KMail2: No more automatic HTML-Display after upgrade from 42.1
KMail2: No more automatic HTML-Display after upgrade from 42.1
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: KDE Applications
Leap 42.2
Other Other
: P5 - None : Normal with 1 vote (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-24 09:02 UTC by Axel Braun
Modified: 2018-04-17 13:53 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Sync of mail folder (12.87 KB, image/png)
2016-11-25 07:46 UTC, Axel Braun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2016-11-24 09:02:39 UTC
Hi have a couple of Newsletters I use to read in HTML.
The mail addresses are in the addressbook, loading external content is enabled, and the default display mode is HTML.
That worked nicely in Leap 42.1.
After upgrade to 42.2 it does not work any longer. I checked all settings but no change compared to before.
Any Idea what I could try?
Comment 1 Wolfgang Bauer 2016-11-24 14:21:05 UTC
And which version?
4.14.10 or 5.3.2?

AFAIK this feature requires pim indexing. So check that baloo-pim (for kmail 4.14) or akonadi-search (for 5.3) is installed.
Comment 2 Fabian Vogt 2016-11-24 14:55:00 UTC
(For KMail 5, I do not consider KMail 4 as officially supported anymore)

Does it appear when you right click into the mail view, select "Show message structure" and then choose the HTML part manually?
Comment 3 Luca Beltrame 2016-11-24 15:02:23 UTC
Can you display HTML if you show the HTML sidebar (in KMail settings) and then clicking on it?
Comment 4 Axel Braun 2016-11-24 20:41:22 UTC
(In reply to Wolfgang Bauer from comment #1)
> And which version?
> 4.14.10 or 5.3.2?

As it is an upgrade - 4.14.10
 
> AFAIK this feature requires pim indexing. So check that baloo-pim (for kmail
> 4.14) or akonadi-search (for 5.3) is installed.

Indeed, baloo-pim is not installed (although I assume it was before). But akonadi-search is installed:

Problem: installiertes akonadi-search-16.08.2-1.1.x86_64 macht baloo-pim < 16.08.2, welches durch baloo-pim-4.14.3-3.6.x86_64 angeboten wird, obsolet
 Lösung 1: Downgrade von akonadi-search-16.08.2-1.1.x86_64 zu akonadi-search-15.12.1-9.1.x86_64
 Lösung 2: baloo-pim-4.14.3-3.6.x86_64 nicht installieren

So it looks like an upgrade problem, correct?

And yes, I can load all HTML content manually and display the message
Comment 5 Axel Braun 2016-11-25 07:46:51 UTC
Created attachment 703714 [details]
Sync of mail folder

Actually the installation of baloo-pim does not change this behaviour.
But akonadi (?) shows an interesting calculation.....
Comment 6 Fabian Vogt 2016-11-25 08:45:23 UTC
KDE PIM 4 is only provided to ease the upgrading process a bit (exporting mails, etc.)
Please update to KMail 5 and reopen if the issue persists.
Comment 7 Axel Braun 2016-11-25 08:47:37 UTC
(In reply to Fabian Vogt from comment #6)
> KDE PIM 4 is only provided to ease the upgrading process a bit (exporting
> mails, etc.)
> Please update to KMail 5 and reopen if the issue persists.

That was really not the answer I wanted to hear....as there is no KNode anymore. Or is it on the way in between?
Comment 8 Fabian Vogt 2016-11-25 08:53:29 UTC
(In reply to Axel Braun from comment #7)
> (In reply to Fabian Vogt from comment #6)
> > KDE PIM 4 is only provided to ease the upgrading process a bit (exporting
> > mails, etc.)
> > Please update to KMail 5 and reopen if the issue persists.
> 
> That was really not the answer I wanted to hear....as there is no KNode
> anymore. Or is it on the way in between?

No, there is no knode available anymore:

> KNodes was not ported to KDE4 pure and there is not a maintainer for it. So it was a big work for me if I wanted to port to pure KDE4 and porting after that to kf5

(http://www.aegiap.eu/kdeblog/2015/08/kdepim-5-0/)
_Maybe_ you'll be able to get the old version installed in parallel with some tricks.
Comment 9 Wolfgang Bauer 2016-11-25 10:25:25 UTC
(In reply to Axel Braun from comment #4)
> (In reply to Wolfgang Bauer from comment #1)
> > And which version?
> > 4.14.10 or 5.3.2?
> 
> As it is an upgrade - 4.14.10

Well, you could have switched to kmail5 before or after the upgrade...

> So it looks like an upgrade problem, correct?

Seems so.
The problem is that akonadi-search obsoletes baloo-pim, but for kdepim4 you'd need baloo-pim.
Maybe we should remove that obsolete for Leap, and only keep it for Tumbleweed for now, where we dropped kdepim4 nearly a year ago already.

(In reply to Axel Braun from comment #5)
> Actually the installation of baloo-pim does not change this behaviour.

Did you uninstall akonadi-search? It may interfere.
Also try to delete the folders in ~/.local/share/baloo/ to force a reindexing (everything except file), maybe akonadi-search updated the database and baloo-pim cannot read it any more.

> But akonadi (?) shows an interesting calculation.....

Yes, I've seen that too (on 13.2 already, which ships with the same kdepim4 versions anyway). Just cosmetical though, it seems to display the number of mails as percentage in some occasions.
Comment 10 Wolfgang Bauer 2016-11-25 10:32:51 UTC
(In reply to Fabian Vogt from comment #8)
> No, there is no knode available anymore:
> 
> > KNodes was not ported to KDE4 pure and there is not a maintainer for it. So it was a big work for me if I wanted to port to pure KDE4 and porting after that to kf5
> 
> (http://www.aegiap.eu/kdeblog/2015/08/kdepim-5-0/)

That's not the full story though.
knode actually has been ported to pure KDE4 and KF5 afterwards by the old maintainer.
It currently rests in a scratch repo:
https://cgit.kde.org/clones/kdepim/otrichet/knode.git/
https://cgit.kde.org/scratch/otrichet/knode.git/

Even though there haven't been any activity since December, I was able to build it against the latest kdepim5 with only minor notifications (and I had to build the nntp kio-slave from kdepimlibs 16.04 stand-alone as it is not included in 16.08 any more).
It works fine for news reading (using QtWebEngine), but posting articles is still missing completely.

So at least there is some hope I suppose.

> _Maybe_ you'll be able to get the old version installed in parallel with
> some tricks.

Well, it requires Akonadi4 and won't work without it running, at least the sending functions and mail account management I think.
Comment 11 Axel Braun 2016-11-29 09:37:52 UTC
I have upgraded to KMail 5 in between, issue persists:
- no automatic HTML display, despite selected for certain Email address
- no load of external content, despite selected for certain Email address
- Email address is now 3 times in address-book (but still has no impact)
- setting (display and load) cant be maintained in addressbook (dependency/package missing?)
Comment 12 Tomáš Chvátal 2018-04-17 13:53:01 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.2 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE, or you can still observe it under openSUSE Leap 15.0, please
feel free to reopen this bug against that version (see the "Version"
component in the bug fields), or alternatively open
a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime