Bug 1001276 - Gwenview cannot display documents of type image/jpeg
Gwenview cannot display documents of type image/jpeg
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: KDE Applications
Leap 42.2
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Antonio Larrosa
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-26 19:50 UTC by Roger Price
Modified: 2016-09-29 08:03 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Gwenview window with error message (29.24 KB, image/jpeg)
2016-09-28 17:14 UTC, Roger Price
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Price 2016-09-26 19:50:37 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build Identifier: 

I attempted to display a jpg image using command qwenview <address of jpg>.
I got a gwenview window with the error message 
"Gwenview cannot display documents of type image/jpeg".
The image format jpeg is not amongst the recognized image formats.

Reproducible: Always

Steps to Reproduce:
1. Type command gwenview <address of jpg image>
2.
3.
Actual Results:  
Error message, see title.

Expected Results:  
Should see jpg image.

Using xfce.  xv successfully displays this jpg image.
Comment 1 Wolfgang Rosenauer 2016-09-27 05:54:17 UTC
wolfi@Hygiea:~> osc maintainer gwenview
Defined in project:  openSUSE:13.1:Update
  bugowner of gwenview : 
   wrosenauer, group:maintenance-opensuse.org

  maintainer of gwenview : 
   wrosenauer, group:maintenance-opensuse.org

For some reason osc only finds the 13.1 version in the update repo and selects me as being maintainer which is wrong in general.

gwenview is a KDE application and the bug opened against 42.2 therefore reassigning.
Comment 2 Per Jessen 2016-09-27 06:22:07 UTC
Hardware:  plain office desktop (office36).
Software:  Leap422b2, vanilla. 

I've just tried this with some photos, over an ssh -X session. On the first attempt:

gwenview IMG_0161.jpeg IMG_0162.jpeg IMG_0163.jpeg

gwenview did not display the images, but when I subsequently tried with:

gwenview IMG_0161.jpeg

it worked fine.
Comment 3 Antonio Larrosa 2016-09-28 14:01:11 UTC
Fixed issue reported by Per Jessen (thanks for the report!). Patch submitted to KDE:Applications (https://build.opensuse.org/request/show/430880) and upstream (https://phabricator.kde.org/D2880).

OTOH, I couldn't reproduce the problem reported in the description and neither could Per, so I'll mark this as fixed. 

Roger, if you think the issue is not really fixed, please reopen it and provide more detailed information on how to reproduce it and the system you're working on.
Comment 4 Bernhard Wiedemann 2016-09-28 16:00:30 UTC
This is an autogenerated message for OBS integration:
This bug (1001276) was mentioned in
https://build.opensuse.org/request/show/431129 42.2 / gwenview5
Comment 5 Roger Price 2016-09-28 17:14:16 UTC
Created attachment 694831 [details]
Gwenview window with error message
Comment 6 Roger Price 2016-09-28 17:17:13 UTC
Additional details for 1001276

Box: Dell Precision T7500
OS: openSUSE 42.2 Beta 2 fresh network install with Xfce window manager.
Additional software: package gwenview5 version 16.08.0 from same source as the
OS.

Action 1: Show image is presentable.  Type command xv
Documents/Images/Stakhanov.jpg

Result 1: See the photo. https://en.wikipedia.org/wiki/Alexey_Stakhanov

Action 2: Attempt to repeat with gwenview.  Type command
gwenview Documents/Images/Stakhanov.jpg

Result 2a: This command produces the following console report:

 rprice@titan:~> gwenview Documents/Images/Stakhanov.jpg
 Reusing existing ksycoca
 Recreating ksycoca file ("/mnt/home/rprice/.cache/ksycoca5_en_vjfayKlGBFQhnCV5hzntPCHfoEc=", version 303)
 Still in the time dict (i.e. deleted files) ("apps")
 Menu "applications-kmenuedit.menu" not found.
 new: "/usr/share/applications/supertuxkart.desktop"
 Saving
 KServiceTypeTrader: serviceType "QImageIOPlugins" not found
 klauncher not running... launching kdeinit
 Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)

Result 2b: The window shown in attached file Gwenview-Attachment.1.jpg

Roger
Comment 7 Antonio Larrosa 2016-09-28 18:07:09 UTC
Hmmm, thanks for explaining you installed gwenview on an xfce desktop. That made me think... can you try running the next commands?

sudo zypper in kimageformats kdelibs4support

That should fix the issue if I'm not wrong. Can you copy here the output of that command? (to check which package was the one that was missing)
Comment 8 Roger Price 2016-09-28 22:38:13 UTC
Action: I typed the command
 script -c "sudo zypper in kimageformats kdelibs4support" /tmp/zypper.log

Result a: I got the script report shown below.  

Result b: gwenview now shows jpg images correctly. :-)

Script started on Wed 28 Sep 2016 11:53:19 PM CEST
root's password:
Loading repository data...
Warning: Repository 'openSUSE-Leap-42.2-Update-Non-Oss' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...
'kimageformats' is already installed.
No update candidate for 'kimageformats-5.26.0-1.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...

The following 2 NEW packages are going to be installed:
kdelibs4support kdelibs4support-lang

The following recommended package was automatically selected:
kdelibs4support-lang

2 new packages to install.
Overall download size: 1.9 MiB. Already cached: 0 B. After the operation, additional 11.4 MiB will be used.
Continue? y/n/? (y):
Retrieving package kdelibs4support-5.26.0-1.1.x86_64                       (1/2), 688.6 KiB (  2.2 MiB unpacked)
Retrieving: kdelibs4support-5.26.0-1.1.x86_64.rpm ..........................................[done (242.5 KiB/s)]
Retrieving package kdelibs4support-lang-5.26.0-1.1.noarch                  (2/2),   1.2 MiB (  9.3 MiB unpacked)
Retrieving: kdelibs4support-lang-5.26.0-1.1.noarch.rpm .....................................[done (236.9 KiB/s)]
Checking for file conflicts: .............................................................................[done]
(1/2) Installing: kdelibs4support-5.26.0-1.1.x86_64 ......................................................[done]
(2/2) Installing: kdelibs4support-lang-5.26.0-1.1.noarch .................................................[done]

Script done on Wed 28 Sep 2016 11:54:17 PM CEST
Comment 9 Antonio Larrosa 2016-09-29 08:03:30 UTC
Thanks for your report and for the testing. I've fixed this now in https://build.opensuse.org/request/show/431198 .