Bug 985376

Summary: GCC6: wammu fails to build
Product: [openSUSE] openSUSE Tumbleweed Reporter: Dominique Leuenberger <dimstar>
Component: OtherAssignee: Dominique Leuenberger <dimstar>
Status: RESOLVED DUPLICATE QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: jengelh
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Bug Depends on:    
Bug Blocks: 984984    

Description Dominique Leuenberger 2016-06-17 09:52:35 UTC
Since the update to GCC6, openSUSE:Factory/wammu fails to build
Comment 1 Michal Čihař 2016-06-17 10:54:57 UTC
First of all this is not a Wammu issue at all (it actually contains no C code) and the only way it is related to GCC6 is that wxWidgets was not yet built by it, while wxPython was:

[  132s] Fatal Error: Mismatch between the program and library build versions detected.
[  132s] The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,STL containers,compatible with 2.6),
[  132s] and wxPython used 2.8 (no debug,Unicode,compiler with C++ ABI 1010,STL containers,compatible with 2.6).

So this is definitely some libraries mess in Factory and not a package bug.

PS: I'm also not maintainer of this SUSE package...
Comment 2 Dominique Leuenberger 2016-06-17 11:06:02 UTC
(In reply to Michal Čihař from comment #1)
> First of all this is not a Wammu issue at all (it actually contains no C
> code) and the only way it is related to GCC6 is that wxWidgets was not yet
> built by it, while wxPython was:

Thanks for looking into it - please understand that I filed > 150 bugs for failed packages and could not check all the logs to find the right info. But glad you did. I will mark the bug as duplicate of the wxWidets failure.

> [  132s] Fatal Error: Mismatch between the program and library build
> versions detected.
> [  132s] The library used 2.8 (no debug,Unicode,compiler with C++ ABI
> 1009,STL containers,compatible with 2.6),
> [  132s] and wxPython used 2.8 (no debug,Unicode,compiler with C++ ABI
> 1010,STL containers,compatible with 2.6).
> 
> So this is definitely some libraries mess in Factory and not a package bug.
> 
> PS: I'm also not maintainer of this SUSE package...

osc maintainer wammu
Defined in package: hardware/wammu 
  bugowner of wammu : 
   prusnak, Nijel

  maintainer of wammu : 
   Nijel


Meta info in the package indicates you are maintainer...

*** This bug has been marked as a duplicate of bug 985238 ***
Comment 3 Jan Engelhardt 2017-02-17 17:07:58 UTC
It's really a problem in wxWidgets and wxPython.

*** This bug has been marked as a duplicate of bug 953017 ***